Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Oct 18, 2006, 12:06 AM   #31
Junior Member
 
Join Date: Oct 2006
Posts: 3
Default

Hello all,

I'm new to the board, looking for some collective wisdom that may help me with a problem along the lines of this thread.

I just received my new Sigma 24-135mm today to pair up with a brand new Pentax *ist DS. The problem I am having with this lens is that the camera won't take pictures with the lens fully seated in the body. "AF" flashes on the LCD and in the viewfinder only. But when I unlock the lens and turn it back VERY slightly, the AF quits flashing and it takes verv nice pictures. Unfortunately, however, auto focus does not work.

I understand that I can purchase some kind of adapter that will do a better job of mating this camera dn lens. Anysuggestions are welcome, as I would like to make this lens work out for me.
meinherzbrennt is offline   Reply With Quote
Old Oct 18, 2006, 11:05 PM   #32
Senior Member
 
thekman620's Avatar
 
Join Date: Feb 2004
Posts: 6,084
Default

This thread has popped up again. I don't like to sound too cynical, but I'd recommend returning it and buying the Tamrom equivlent. I gave up on mine. Was too irritating to use with the menu malfunctions, and for an extra $100, I found a Tamron. It also started losing it's AF lock ability. I traded the Sigma in and got $250 for it on another different purchase. It worked fine for the camera store, but not for my camera. Quirky lens...Don.


meinherzbrennt wrote:
Quote:
Hello all,

I'm new to the board, looking for some collective wisdom that may help me with a problem along the lines of this thread.

I just received my new Sigma 24-135mm today to pair up with a brand new Pentax *ist DS. The problem I am having with this lens is that the camera won't take pictures with the lens fully seated in the body. "AF" flashes on the LCD and in the viewfinder only. But when I unlock the lens and turn it back VERY slightly, the AF quits flashing and it takes verv nice pictures. Unfortunately, however, auto focus does not work.

I understand that I can purchase some kind of adapter that will do a better job of mating this camera dn lens. Anysuggestions are welcome, as I would like to make this lens work out for me.
thekman620 is offline   Reply With Quote
Old Oct 19, 2006, 10:22 PM   #33
Senior Member
 
Fred2726's Avatar
 
Join Date: Oct 2006
Posts: 305
Default

I just spoke to Simga today after sending my lens back to them for the second time. The first time it was returned unrepaired, this time they state they replaced a part. Did not go into any other details than replacing a part. When I speak to people in the service department they seem to act like i'm the only person having this problem... Why obviously isn't the case. I will report back once the lens is in my hands and see if it resolves the flickering menu/function buttons.

PS - Did anyone else notice that Cameta raised the price on EBay to $149 US. Up $50 from just a couple days ago. Think, you could've paid $50 more for a lens that doesn't work right on your camera.

Does anyone have any experience with the Tamron 24-135mm lens? Reviews on Fred Miranda seem to be alot better than the Sigma, plus the macro is always good.
Fred2726 is offline   Reply With Quote
Old Oct 20, 2006, 12:20 AM   #34
Senior Member
 
thekman620's Avatar
 
Join Date: Feb 2004
Posts: 6,084
Default

The Tamron is very good. No problems whatsoever with mine. I'd recommend it if you're having the usual Sigma problems........cheers......Don.


Fred2726 wrote:
Quote:
I just spoke to Simga today after sending my lens back to them for the second time. The first time it was returned unrepaired, this time they state they replaced a part. Did not go into any other details than replacing a part. When I speak to people in the service department they seem to act like i'm the only person having this problem... Why obviously isn't the case. I will report back once the lens is in my hands and see if it resolves the flickering menu/function buttons.

PS - Did anyone else notice that Cameta raised the price on EBay to $149 US. Up $50 from just a couple days ago. Think, you could've paid $50 more for a lens that doesn't work right on your camera.

Does anyone have any experience with the Tamron 24-135mm lens? Reviews on Fred Miranda seem to be alot better than the Sigma, plus the macro is always good.
thekman620 is offline   Reply With Quote
Old Oct 20, 2006, 5:11 PM   #35
Senior Member
 
NonEntity1's Avatar
 
Join Date: Jul 2006
Location: Lake Placid Florida USA
Posts: 2,689
Default

Fred2726 wrote:
Quote:
PS - Did anyone else notice that Cameta raised the price on EBay to $149 US. Up $50 from just a couple days ago. Think, you could've paid $50 more for a lens that doesn't work right on your camera.
I had not seen that this lens had gone up but I had noticed that the prices of several Pentax lenses from Cameta have gone up quite a bit since I got my camera in August. The Tamron 70-300DI is higher, the Tamron 28-300 has gone through at least two price increases, and the two Pentax 28-80 lenses they carry are now higher also. I am taking this to mean that the K100d has proven to be quite popular and greatly increased demand.

Tim
NonEntity1 is offline   Reply With Quote
Old Oct 20, 2006, 5:58 PM   #36
Senior Member
 
Join Date: May 2005
Posts: 189
Default

Oops!

Tamron SP AF24-135mm F/3.5-5.6 AD Aspherical (IF)

or

Sigma AF 24-135mm F2,8-4,5

How can we compre, folks? Or am I missing something again?

Best, JR

Reps is offline   Reply With Quote
Old Oct 23, 2006, 3:34 PM   #37
Senior Member
 
Fred2726's Avatar
 
Join Date: Oct 2006
Posts: 305
Default

Good News,

After two returns to Sigma they've returned my 24-135mm lens repaired and now working properly with my Pentax DL! Great news as I really love the lens.

I will commend Sigma on they're very speedy repair and return!




Fred2726 is offline   Reply With Quote
Old Oct 24, 2006, 11:31 PM   #38
Junior Member
 
Join Date: Oct 2006
Posts: 3
Default

Thanks for the reply to this everyone.

Fred2726, It sounds like you talked to the right people at Sigma. Unfortunately their so called "Pentax expert" was less than helpful for me. When I tried to explain the problem, he cut me off and said that they NEVER have any problems when they put returned lenses on their *ist DS cameras. He referred me back to cameta, who told me lens I returned is fine, and works with their K100s. However, they don't have an *ist DS camera body to test the Sigma on, so I'm not sure how they can surmise that I don't have problem. I'm also not sure how they can claim on ebay that the lens works with the DS if they've never tested it on one.

I'm hoping the replacement lens that Cameta sends will work. Otherwise, I could use the name of your contact person at Sigma. Perhaps they may be more helpful than the one I had the displeasure to converse with.


Fred2726 wrote:
Quote:
Good News,

After two returns to Sigma they've returned my 24-135mm lens repaired and now working properly with my Pentax DL! Great news as I really love the lens.

I will commend Sigma on they're very speedy repair and return!



meinherzbrennt is offline   Reply With Quote
Old Oct 25, 2006, 4:16 PM   #39
Senior Member
 
Fred2726's Avatar
 
Join Date: Oct 2006
Posts: 305
Default

meinherzbrennt


I spoke to a gentleman named Rory at the US service center. He had me send the lens in to his attention. Took only 6 days from the day I sent it in to the day I recieved it back (saturday delivery I might add). So far no problem since the repair.
Fred2726 is offline   Reply With Quote
Old Oct 31, 2006, 1:57 AM   #40
Member
 
Join Date: Aug 2006
Posts: 45
Default

I bought two of these lenses, the first had absolutely no problem. The second was for my dad, unforunately, it seems like one of the contacts doesn't have a great connection as the MF light appears sometimes (meaning that the lens won't autofocus) and other times it's okay. Removing and reseating the lens makes no difference.

I spoke with Gentec and they suggested that I bring it in. Does anyone have any suggestions before I send it for service?

Both were purchased from Cameta, and I wish I tested this one more initially as I could have just returned/repurchased from Cameta.

I'm glad to hear that everyone has had their lenses fixed by the service center though.
intence is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:37 AM.