Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old May 15, 2006, 5:47 PM   #1
Senior Member
 
Join Date: May 2006
Posts: 168
Default

Well I guess I was not one of the lucky ones ... my DL does not recognize this lens. Rear display flashes one and then goes blank. Real PAIN. Suppose it will need to head back to Cameta. Stuck with shipping both ways and tax at border for a lens that doens't work :-(.

Did anyone with a "defective" one find a solution?

Cheers, Mike
mgedit is offline   Reply With Quote
Sponsored Links
Old May 15, 2006, 6:42 PM   #2
Senior Member
 
Monza76's Avatar
 
Join Date: Jul 2004
Posts: 4,095
Default

I am very sorry to hear that the lens did not work out for you, I guess I was lucky. I have earned over $200 in photo jobs which I shot with this lens so it has paid for itself over two times now. Sigma should be replacing these lenses with examples that actually worksince it is a very nice lens (once you get past the weight.

Again, I hope you can get this resolved in a timely and economically satisfactory manner.

Ira
Monza76 is offline   Reply With Quote
Old May 15, 2006, 7:59 PM   #3
Guest
 
Posts: n/a
Default

i think i'd be calling cameta and sigma about this. there's bound to be a better recourse..

roy
  Reply With Quote
Old May 15, 2006, 8:27 PM   #4
Senior Member
 
Join Date: May 2006
Posts: 168
Default

I agree with both Ira and Roy ... there is definitely an issue with these lens. If either the seller or manufacturer was aware of it and decided to dump them then neither one these is particulary reputable, or a company I'm much interested in dealing with again. Kinda leaves a bad taste. FYI I do intend to puruse this with both to try to get a satifactory conclusion. Will keep the list informed.
mgedit is offline   Reply With Quote
Old May 15, 2006, 8:55 PM   #5
Guest
 
Posts: n/a
Default

appreciated!!

roy
  Reply With Quote
Old May 15, 2006, 9:13 PM   #6
Senior Member
 
Dr. C's Avatar
 
Join Date: Jan 2006
Location: Sequim, WA
Posts: 282
Default

Hope something works out for you. I was fortunate to receive one that works okay. Seems to be a mixed report on quality about this lens.

Lawrence
Dr. C is offline   Reply With Quote
Old May 15, 2006, 10:36 PM   #7
Senior Member
 
thekman620's Avatar
 
Join Date: Feb 2004
Posts: 6,084
Default

mgedit wrote:
Quote:
Well I guess I was not one of the lucky ones ... my DL does not recognize this lens. Rear display flashes one and then goes blank. Real PAIN. Suppose it will need to head back to Cameta. Stuck with shipping both ways and tax at border for a lens that doens't work :-(.

Did anyone with a "defective" one find a solution?

Cheers, Mike

Sorry to hear all of the problems you're having with this lens. It seems the quality control or design of this lens is a big problem. Looks like Sigma dumped them to Cameta, and they're flogging them off to an unsuspecting public. There should be a disclaimer of some sort when purchasing this lens from ebay. I thought the price was too good to be true. Mine is quirky for the fn button, but seemsto work ok if you can manage to make the changes in the fn settings. I would contact Cameta, and tell them what is happening, and ask them to pay the shipping charges for the return. Thelens is obviously defective. And I wouldn't get a replacement either. Go for the refund, and write it off to experience. I expect mine to sometime in the future go belly up. Hope it doesn't, but this is the 2nd Sigma lens I've owned, and the first was a dog too. It didn't auto focus properly. I don't thinkI'll bepurchasing any moreSigma lenses. I've had 2 negative experiences with them, and have heard of numerous others........Don.
thekman620 is offline   Reply With Quote
Old May 15, 2006, 10:42 PM   #8
Junior Member
 
Join Date: Mar 2006
Posts: 7
Default

I bought this lens 2 weeks ago and had the same issues. I called sigma and they told me to send it in for a 'software' update.

i opted to return the lens since i live locally.

one option may be to send it to sigma for the 'update'

opiecat is offline   Reply With Quote
Old May 16, 2006, 8:06 AM   #9
Guest
 
Posts: n/a
Default

i've never heard of sigma charging to rechip a lense. even if it's way out of warranty. if they have the chip..
  Reply With Quote
Old May 16, 2006, 8:16 PM   #10
Senior Member
 
Join Date: May 2006
Posts: 168
Default

Contacted Cameta Camera today. They replied promptly by email and telephone. They suggested cleaning the contacts and trying the lens on another body. Their suggestion was to send it to the Sigma Canada authorized repair facility for warantee repair:Gentec International, 90 Royal Crest Court, Markham, Ontario, L3R 9X6

I sent Gentec an email and copied it to Cameta. Will post further developments as they occur.

I told the Cameta customer service guy that there had been several other users with similar problems with this lens as reported in this forum. He said he was unaware of any issues with other users and confirmed that the lens definitely works with the DL.

Cheers, Mike
mgedit is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:31 AM.