Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Aug 10, 2006, 6:29 AM   #1
Senior Member
 
Join Date: Sep 2004
Location: Wigan, UK
Posts: 568
Default

I bought Vivitar series 1 70-210 f2.8-4. It doesn't have na A mark on aperture ring, instead it has P. Is it the same? And if yes why it doesn't work in Av mode??


gfurm is offline   Reply With Quote
Sponsored Links
Old Aug 10, 2006, 7:50 AM   #2
Senior Member
 
Peacekeeper's Avatar
 
Join Date: Jan 2006
Posts: 1,024
Default

Are there any contacts for info to be transmitted from the lens to the camera? Maybe "P" isn't the same as "A".


Peacekeeper is offline   Reply With Quote
Old Aug 10, 2006, 7:56 AM   #3
Junior Member
 
Join Date: Apr 2005
Posts: 7
Default

Seems to me that the lens isn't made for Pentax KA (K-mount with auto-aperture function), it's made for the Ricoh version of this moun (known as Ricoh KP/AR). That's why it doesn't work. They're physically compatible, but not electrically. Lenses for the Ricoh mount should be avoided on Pentax autofocus and DSLR's bodies because they can get stucked.

Take care

R

rolandm is offline   Reply With Quote
Old Aug 10, 2006, 8:26 AM   #4
Senior Member
 
Join Date: Sep 2004
Location: Wigan, UK
Posts: 568
Default

rolandm: I think you may be right, there's a R-P/K mark on it andwhen I checked both this and my 50mm pentax lens there's one connection missing on vivitar,I suppose it's for auto aperture. luckily lens doesn't get stuck on my dl. I just have to use it in M mode.



thanks for response
gfurm is offline   Reply With Quote
Old Aug 10, 2006, 8:44 AM   #5
Guest
 
Posts: n/a
Default

it's still a really nice lense even if you have to use it in M mode..
  Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:03 AM.