Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Aug 29, 2006, 4:50 AM   #1
Junior Member
 
Join Date: Aug 2006
Posts: 11
Default

i finally got my new pentax *ist dl in the mail today.my dad and brother had pentax k1000's, and they seemed like a great camera, but i had to have digital. I went with the pentax *ist DL with a sigma 24-135mm f2.8 lens.



the lens hasnt gotten here yet, so i decided to try out some of the k1000 lenses but they dont work. they fit on the camera just fine. why wont my k1000 lenses work on my *ist DL? i only get a flashing Av...nothing else.

i thought the lenses should work? one is a 70-200 zoom with close focus, the other im not sure. they connect to my camera just fine, but i cant take any pictures.
cheyne is offline   Reply With Quote
Sponsored Links
Old Aug 29, 2006, 5:23 AM   #2
Senior Member
 
Join Date: Feb 2006
Posts: 150
Default

Someone should make FAQ about using old lenses on digital Pentax bodies

To make them work you must do following:
1) Go to "Custom Setting" menu and set "Using aperture ring" to "Permitted". By default it is "Prohibited".
2) Set camera to "M" (Manual) mode.
3) Set aperture on your lense.
4) Measure exposure by pressing AE-L
5) Take a picture
6) return to step 5. If lighting conditions changed , return to step 4. If you change aperture, go to step 3

That's it!
Edvinas is offline   Reply With Quote
Old Aug 29, 2006, 5:46 AM   #3
Junior Member
 
Join Date: Aug 2006
Posts: 11
Default

thank you! i've been dying to play with the camera.



look out for some pictures in the near future!
cheyne is offline   Reply With Quote
Old Aug 29, 2006, 10:22 AM   #4
Senior Member
 
mtngal's Avatar
 
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,056
Default

For focusing - if you have the camera set to auto focus, the shutter won't release if the camera doesn't indicate it is in focus (look for the focus indicator) - can be useful if you don't want to take time to dial in the focus - line it up, press the shutter and turn the focus ring, the shutter will go when the camera take the picture when it says its in focus. If you have it set to manual focus, the shutter will release regardless.
mtngal is offline   Reply With Quote
Old Sep 2, 2006, 8:30 AM   #5
Senior Member
 
nlp239's Avatar
 
Join Date: Jan 2005
Posts: 719
Default

I have the istD and firmware is up-to-date and I do not have or I can't find

Quote:
Go to "Custom Setting" menu and set "Using aperture ring" to "Permitted". By default it is "Prohibited".
jc
nlp239 is offline   Reply With Quote
Old Sep 2, 2006, 9:16 AM   #6
Senior Member
 
Join Date: Jun 2006
Posts: 179
Default

I believe this is an option in the DL

F

nlp239 wrote:
Quote:
I have the istD and firmware is up-to-date and I do not have or I can't find

Quote:
Go to "Custom Setting" menu and set "Using aperture ring" to "Permitted". By default it is "Prohibited".
jc
fghouse2000 is offline   Reply With Quote
Old Sep 2, 2006, 9:28 AM   #7
Senior Member
 
bilybianca's Avatar
 
Join Date: Nov 2005
Location: Hassleholm, Sweden
Posts: 3,435
Default

nlp239 wrote:
Quote:
I have the istD and firmware is up-to-date and I do not have or I can't find

Quote:
Go to "Custom Setting" menu and set "Using aperture ring" to "Permitted". By default it is "Prohibited".
I downloaded(http://www.pentax.com/docstore/index.cfm?show=6) the *istD manual and found it on page 128. It is named differently, though. Under "Custom Settings" one option is "F stop other than A" which should be set to "on", default is "off".

Kjell
bilybianca is offline   Reply With Quote
Old Sep 2, 2006, 12:08 PM   #8
Senior Member
 
nlp239's Avatar
 
Join Date: Jan 2005
Posts: 719
Default

Thanks Kjell - I found it but sometimes it works sometimes not. Must find time to play around a little more.

Thanks for helping everyone.
nlp239 is offline   Reply With Quote
Old Sep 2, 2006, 12:34 PM   #9
Junior Member
 
Join Date: Aug 2006
Posts: 11
Default

it worked great for me. i dont have any firmware updates though, should i get these? what changes do they make?



my sigma 24-135 finally came in.....i havnt touched my old lenses since!:love: i love it
cheyne is offline   Reply With Quote
Old Sep 2, 2006, 12:43 PM   #10
Senior Member
 
nlp239's Avatar
 
Join Date: Jan 2005
Posts: 719
Default

Cheyne, you should at least check. The first thread in this forum provides the links.
nlp239 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:53 AM.