Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Sep 20, 2010, 11:31 PM   #11
Senior Member
 
Join Date: Sep 2010
Posts: 142
Default

ya that is what it was like in the show room, so of course i get a lemon....i called there too and thatis what they said, it should be almost as quick as a point and shoot. i think someone or something is trying to tell me not to get this camera... arg... after all the research i did and asked a million quections, read a million reviews and i get a LEMON.. go figure! they told me to bring it back to the store in a few days and they would check out setting etc just to make sure ... what setting could i have it on that would delay it to the lcd???

when i test it out with no card in teh camera it's super quick....like it should be
lin7604 is offline   Reply With Quote
Old Sep 20, 2010, 11:35 PM   #12
Super Moderator
 
Hards80's Avatar
 
Join Date: Nov 2004
Location: Cleveland, OH
Posts: 9,046
Default

did you format your card in your camera.

did you try a 2nd card?
__________________
MyFlickr
Hards80 is offline   Reply With Quote
Old Sep 20, 2010, 11:40 PM   #13
Senior Member
 
Join Date: Sep 2010
Posts: 142
Default

no b/c i don't want to lose all the pictures thati have on it from my f70erx... will that make the difference i need? i don't have another card, the other card is only a sd 1 gb
lin7604 is offline   Reply With Quote
Old Sep 20, 2010, 11:42 PM   #14
Senior Member
 
shoturtle's Avatar
 
Join Date: Dec 2009
Location: Frankfurt AM
Posts: 11,348
Default

It could be a bad card as hards pointed out. I would try another one if you have one. Do you have on from you point and shoot, even a class 4 will work for photos.
__________________
Super Frequent Flyer, no joke. Ex Patriot and loving it.
Canon Eos 60D, T1i/500D, Eos1, Eos 630, Olympus EPL-1, and a part time Pentax K-X shooter.
shoturtle is offline   Reply With Quote
Old Sep 20, 2010, 11:45 PM   #15
Super Moderator
 
Hards80's Avatar
 
Join Date: Nov 2004
Location: Cleveland, OH
Posts: 9,046
Default

move your pictures off the card and save them on your computer.

burn them on a cd as backup, whatever you need to do.

but you really need to format the card in the camera you are using it, so that it can set up its file structure. it could be causing you problems.

the reason i say this is because it works fine without the card.
__________________
MyFlickr
Hards80 is offline   Reply With Quote
Old Sep 20, 2010, 11:48 PM   #16
Senior Member
 
Join Date: Sep 2010
Posts: 142
Default

ok i will do that tomorrow. thanks so much for all your help everyone. I don't have another card besides the basic 1gb card that was from my kodaz Z740. the one i put in the new pentax was from my fuji F70 erx and it was 4gb clas 6. that's all i have.... if formatting it doesn't work i will buy a new one to see if that makes a difference and if not then i'll take it back to the store. is there a specific card that is better then another or it doesn't matter as long as it's at least a class 6?
lin7604 is offline   Reply With Quote
Old Sep 20, 2010, 11:56 PM   #17
Super Moderator
 
Hards80's Avatar
 
Join Date: Nov 2004
Location: Cleveland, OH
Posts: 9,046
Default

yea, let us know how that works out for you. it just may work given your experience without the card in it. i think the f70exr file structure may be slowing down the pentax.

any class 6 or better should be fine.
__________________
MyFlickr
Hards80 is offline   Reply With Quote
Old Sep 21, 2010, 2:44 AM   #18
Senior Member
 
Join Date: Aug 2009
Posts: 629
Default

One thing I read too, was, format using the camera and not the computer.

I was told top format every time I transferred pics.
littlejohn is offline   Reply With Quote
Old Sep 24, 2010, 4:38 AM   #19
Junior Member
 
sledger's Avatar
 
Join Date: Aug 2005
Posts: 18
Default

If you're shooting RAW, writing to a slower card will take some time before the embedded JPEG shows on the LCD.
Bright sunny day photos will be larger (megabytes) than darker shots.

How you format the card makes little difference (if any) in my experience with the *istDS and K-7.
sledger is offline   Reply With Quote
Old Sep 26, 2010, 10:12 PM   #20
Senior Member
 
Join Date: Sep 2010
Posts: 142
Default

ok, so i bought a brand new card, formatted it to the camera too and NO difference!!!! without the card it's super quick a split second and the picture is on the lcd. With a sdhc class 6 card it takes 4-5 secs at least for the picture to show up????? why such a delay? the new card i bought is even a different brand then i had last time.... It wasn't set on raw either.... not sure what's up?? i guess on tueday i may have to take it back and maybe just exchange it for the canon sx 18-55 lense and the 55-200 extra leanse that it come with. I really like this camera so far, it has impressed me, theonly thing that is the deal breaker is the super slowness of the picture showing up on the lcd. I tell ya, you will miss a ton of shots like this, by the time you see what you took, the subject is no longer there...
lin7604 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:32 PM.