Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Sep 13, 2004, 8:02 PM   #1
Junior Member
 
Join Date: Sep 2004
Posts: 4
Default

Hello there.

My Optio S4 got a problem. I checked this site, and some people had same problems with me.

Mine is also "A90" error. - It works well without SD card, but it dies with SD card.

Unfortunately, I bought it in Korea and don't have international warrnty. I broughtitto the lab in Vancouver, they said it would cost $100! But what theydo is just reinstalling the firmware software.

Does anybody know where to download the firmware optio s4?

I can find optio S4i firmware software, but I guess it doesn't fit to S4, is it?

Somebody help me! Thanks!


tanykim is offline   Reply With Quote
Sponsored Links
Old Sep 14, 2004, 2:26 AM   #2
Member
 
HappyMac's Avatar
 
Join Date: May 2004
Posts: 57
Default

Hi Tanykim,

There is no FW update for the S4 available! Do not try the one for the S4i which has additional hardware features and thus different FW.

Are you sure your card is OK? Have you tried another card in your cam? Some cards seem to have compatability problems in the Optios.

Mark
HappyMac is offline   Reply With Quote
Old Sep 17, 2004, 4:05 AM   #3
Junior Member
 
Join Date: Sep 2004
Posts: 4
Default

Thanks for your reply.

Yes, My SD card has no problem.

I made up my mind to send it Korea. T_T and I'll buy a new one..
tanykim is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:09 AM.