Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Jan 22, 2005, 2:05 PM   #21
Member
 
Info_Man's Avatar
 
Join Date: Jan 2005
Posts: 36
Default



Hey schnuddy,

Glad to hear you're up and running...

Enjoy the camera..



Info_Man
Info_Man is offline   Reply With Quote
Old Jan 22, 2005, 10:43 PM   #22
Junior Member
 
Join Date: Jan 2005
Posts: 4
Default

Hi Info_Man,

I've two computers at home. One has WinXP and other one has Win98. I followed your instructions and was able to get S40 to work with Win98. However, I cannot get S40 to work on WinXP. I keep getting unknown Device in my device manager :sad:. Is there a driver for S40_winXP?

Thanks,

Simba
simba is offline   Reply With Quote
Old Jan 23, 2005, 12:41 AM   #23
Member
 
Info_Man's Avatar
 
Join Date: Jan 2005
Posts: 36
Default



Hey Simba,

The Optio S40 conforms to USB Mass Storage and compatible Operating Systems such as Windows Me, 2000, XP Home, XP Pro, will build their own USB Mass Storage Driver. Therefore, USB Drivers are not required for the above.

Check the cameras setup menu to be sure the cameras "USB Connection" is set to PC and not "PictBridge".

Power Camera "On" and Push the "Menu" button.

Push the "Right Arrow" button 3x to enter "Setup".

Push the "Down Arrow" button until you see "USB".

Push "Right Arrow" button to change between "PC" and "PictBridge".





[align=center]Also did you read my post aboveRE: "Possible Device Conflict" ?[/align]


[align=center][/align]

Possible Device Conflict:


If you had a "Kodak - Easy Share" installed, then remove all traces of it.

Possible Software Conflict:

AntiVirus:

If you have antivirus software such as Norton or Symantec, then I would suggest that you (Dissable Auto Protect) then try connecting the camera again. It's possible that your antivirus software is recognizing the camera as an intruder.

Firewall:

Also if you havea Firewall you may have to go into it's configurationtogive you camera acess. I know that the followingFirewalls always tend to causeconflicts (Freedom or ZoneAlarm). If you don't know how to configure it to give the camera access, I would suggest that you call or e-mail the manufacturer of the Firewall for support.

Alternatively, you could try connecting the camera to a different USB Port. In most cases ifthe Firewall is causing the conflict it will ask you if you would like to grant the camera acess when it is first detected. A "Blah, Blah, Blah," noticeshould appear on you screen. At that point you could allow the camera to be recognized by the Firewall and all is fine.


Also, if your systems is Windows XP Pro, make sure you have ADMINISTRATOR priviledges on your profile.


Keep me up to date...



Info_Man
Info_Man is offline   Reply With Quote
Old Jan 23, 2005, 1:19 PM   #24
Junior Member
 
Join Date: Jan 2005
Posts: 4
Default

Hi Info_Man,

Thanks for your quick response. I've tried everything you mentioned in your post. But nothing seems to work.

Here is what I have noticed. When I bought the first camera, It was doing exactly this. It would appear as Unknown Device. The store I bought it from couldn't help, so they asked me to try a different camera. So they replaced it for me. The second camera (current camera) worked fine for few weeks. XP was able to detect and install the device just fine. I was using it all this time until yesterday, when I wanted to transfer some images of snow-fall I captured, it went back to the original problem of Unknown Device. I searched the web and found your post on how to configure S40 on Win98. Since I had another PC with Win98, I gave it a shot and it worked. So I figured, it might be an issue of drivers. Some reviews on the webof S40 had mentioned that the CD-ROM in the box comes with USB drivers. I couldn't find it on the CD-ROM. I also went to Pentax.ca website, but couldn't find it there as well. Thats when I thought I should ask you, The Expert. I know my USB works fine. I know the camera works find (since it works on Win98). The only thing I can think off is drivers for XP. Any comments?

- Simba
Attached Images
 
simba is offline   Reply With Quote
Old Jan 23, 2005, 1:29 PM   #25
Member
 
Info_Man's Avatar
 
Join Date: Jan 2005
Posts: 36
Default



Hey Simba,

I can assure you that the Optio S40 CD-Rom does not contain any USB Drivers.

However, I noticed in the "systray" of your screen shot the "Local Area Lan" connection indicating you have a network!



NETWORKING & WIN XP

In the release notes for XP under "Storage", it states:

"

Logical volume manager

Local device drive names (a letter of the alphabet) are usually assigned incrementally starting from the letter C, and network drive names are automatically assigned starting from Z in reverse order (Z, Y, etc.).

Drive letter conflicts with existing network shares might result when connecting digital cameras or other consumer devices that use memory sticks to Windows XP while the computer is turned on. The same conflict might occur when adding external drives (such as USB or 1394 disks). In the event of a naming conflict with an existing network share, the local device will not be accessible.

To work around this issue, allow Windows to automatically assign network drive names or choose drive name letters later in the alphabet.

"

In this case the mapped drive (PC2//D) was consecutive on the system, it fell as "O" right after the CD-ROM. In this case it's reason this cause a conflict as mentioned above. Disconnect the mapping to this drive and WinXP should recognize camera. In this case we remapped PC2//D to "Z" and everything was fine.

Keep me posted and let me know if this works.

Info_Man
Info_Man is offline   Reply With Quote
Old Jan 23, 2005, 2:39 PM   #26
Junior Member
 
Join Date: Jan 2005
Posts: 4
Default

Info_Man,

I don't have any networked drives mapped. My second computer (win98)is always off. Local Area Lan Connection indicator in SysTray displays link activity only. I don't map drives automatically. When I want to transfer files between the computers, I usually map drives manually.

S40 used to work fine. I just transfered files on Friday. It used to map itself as i:\ drive all this time without any problems. Not until yesterday that S40 started acting up. I am really running out of options. Any other suggestion? Thanks,

-Simba
simba is offline   Reply With Quote
Old Jan 23, 2005, 4:34 PM   #27
Member
 
Info_Man's Avatar
 
Join Date: Jan 2005
Posts: 36
Default



Hey Simba,

Are you Canadian? If yes click on my profile and use that e-mail address to send me an e-mail. I will reply with my contact information and you can contact me tomorrow.

If you are notCanadian, then just let me know and I will see what I can do for you.

I supposewe could always usethe Windows XP "Remote Assistance" to see if I can figure it out... That is if you are comfortable with that?

I sounds like a device or software conflict to me...

Let me know..

Info_Man


Info_Man is offline   Reply With Quote
Old Feb 2, 2005, 5:26 PM   #28
Junior Member
 
Join Date: Feb 2005
Posts: 1
Default

:?I've tried everything that you've suggested to get my win98 pc to detect my S50 and still can't get my computer to detect the camera. i know that the camera is trying to connect (when it's plugged in all the appropriate lights flash). and i know that the computer detects the camera as a USB device. but, the device detector won't detect the camera and the computer just thinks the camera is a USB device! HELP!!! i'm going a bit crazy with it! :O
alexral is offline   Reply With Quote
Old Feb 4, 2005, 6:05 AM   #29
Member
 
HappyMac's Avatar
 
Join Date: May 2004
Posts: 57
Default

alexral,

You are talking about the S50 and this cam is definitely compatible with Win98.

Have you triedto use a photo manager program to import directly from the camera. There are certainly many of them but the first one for Win98 I have found which is supposed to be capable to do that is: http://www.tucows.com/preview/368685.html

Give it a try!

HappyMac is offline   Reply With Quote
Old Feb 4, 2005, 9:22 AM   #30
Member
 
Info_Man's Avatar
 
Join Date: Jan 2005
Posts: 36
Default



Hey Alexral,

Contraire to what "HappyMac" said.The Optio S50 is not compatible with Win98. Not out of the box that is,but the PDF file that I made makes it compatible.

If you open "My Computer" do you see the "Removable Disk"? If yes try "double clicking" it to open it. Then "double click the "DCIM" & "100PENTX" folder. You should now see all of you images.

If you pushandhold the"Crtl" + "A"keythis will select all.

Then push and hold the "Ctrl" + "C" key to copy.

Now open"My Documents" then "My Pictures" and create a new folder "File New" and give the folder a name.

Then "Double Click" on the new folder to open it.

Now simply push and hold the "Crtl" + "V" key to paste the images.

************************************************** ********************

If you are not able to access the "Removable Drive" then check the following.

#1. When the camera is connected to the computer and the power is on, check to make sure that the LENS on the Optio S50 is "IN" the body. If the lens is not in the body then your computer is not recognizing the camera and I would suggest that you try a different USB port.

#2. If you have "ZONE ALARM" or some other "FireWall" software, then I would suggest that you"Reboot" you computer. Then before connecting the camera,"Shut Down" your "FireWall" then try connecting the camera.

#3. If you have any typy of "AniVirus" software, then I would suggest that you"Reboot" you computer. Then before connecting the camera,"Dissable Auto Protect" or"Shut Down" your "FireWall" then try connecting the camera.

#4. It's possible that your SD Card is causing the problem. Try removing the SD Card and taking some sample pictures using the internal memory. Then connect the camera to your computer to see if the computer will detect it and allow transfer from the internal memory. If it works then you will have to fromat the camera using the cameras interal format option. If the pictures on the card are important then I would suggest going to a photolab and have them print or transfer the photos to a CD for you.

#5. Check the "Device Manager" while the Camera is connected to the computer. If you see an "Unknown Device" or any reference to "Pentax" listed under "Other Devices" remove it and try again.

Well I hope this works...

Let me know how you make out...



Info_Man
Info_Man is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:32 PM.