Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Sep 20, 2004, 9:57 AM   #1
Junior Member
 
Join Date: Sep 2004
Posts: 3
Default

In most tests the S40 is said to be USB compatible with Windows 98. This is NOT TRUE. :XThere is no driver available. Pentax doesn't have a good solution, only an extra card reader. If someone finds a working driver, please inform me.
Andretti is offline   Reply With Quote
Sponsored Links
Old Sep 21, 2004, 5:03 AM   #2
Member
 
HappyMac's Avatar
 
Join Date: May 2004
Posts: 57
Default

Hi Andretti,

On the Swiss page of Pentax there is a download for Win 98/SE USB drivers for all Pentax Optio cams.

Try it: http://www.pentaxfoto.ch/usb_treiber_win98/usb98.zip

Good luck

Mark
HappyMac is offline   Reply With Quote
Old Sep 23, 2004, 10:37 AM   #3
Junior Member
 
Join Date: Sep 2004
Posts: 3
Default

Tnx HappyMac, I will try it

style="BACKGROUND-COLOR: #000000"B.R.

style="BACKGROUND-COLOR: #000000"Andretti
Andretti is offline   Reply With Quote
Old Oct 1, 2004, 6:46 AM   #4
Junior Member
 
Join Date: Sep 2004
Posts: 3
Default

The swiss website SAYS the driver is working for every Optio. This is not true, unfortunately. For my Optio S40 it DOESN'T work.

Greetings,

Andretti
Andretti is offline   Reply With Quote
Old Oct 13, 2004, 1:51 PM   #5
Junior Member
 
Join Date: Oct 2004
Posts: 1
Default

This may help in connecting an OPTIO S40 to a windows 98SE USB, if you download the unofficial service pack version 1.6.2 for windows 98SE and install it this will update your windows 98SE to allow USBmass storage to work, ive found this out after my brother just bought an OPTIO S40 only to discover that not only is there no windows 98 drivers, but the pentax drivers page is under construction and doesn't let you download any drivers for any of their cameras, not very good if you ask me.

this service pack is downloadable from http://www.majorgeeks.com/download4131.html

good luck, it worked for me!
BaxtersCycles is offline   Reply With Quote
Old Jan 5, 2005, 10:44 AM   #6
Junior Member
 
Join Date: Jan 2005
Posts: 1
Default

Hi,

I've just bought a Pentax S40 camera and have had this Windowsw 98 problem. I'm not the most computer literate person but when I downloaded the unofficial service pack from major geeks and installed it, the computer runs only in safe mode and I can get it to start in normal mode.

I've been to heaps of websites and have tried just about everything they suggest and still no luck. So if anyone out there could help me or give me some ideas it would be appreciated.

Thanks Smithdawg
Smithdawg is offline   Reply With Quote
Old Jan 8, 2005, 8:18 PM   #7
Member
 
Info_Man's Avatar
 
Join Date: Jan 2005
Posts: 36
Default

Hey Guys,

Here is what you need to get it working....

Unfortunately, the Optio S40 is not compatible with Windows 98 as mentioned on the box and in the PC Connection manual. The Optio S40 conforms to USB MASS STORAGE Specifications and compatible Operating Systems will automatically detect the Optio S40 and build their own USB Mass Storage Drivers.

Therefore, the included CD-Rom does not contain any USB Drivers as they are not required.

With that being said I have found a way to connect the Optio S40 to a Windows 98/SE platform using the Optio 450/550 USB Drivers. I am including further support information below.

You will need to have Adobe Acrobat Reader installed on your system to view the instructions on how to connect the Optio S40 to Windows 98. If you do not have Adobe Acrobat Reader installed you can download it from the link below.



Adobe Acrobat Reader - Download

http://www.adobe.com/products/acrobat/readstep2.html

How To Connect - Optio s40 - Windows 98 PDF File

http://www.pentax.ca/support/s40/optio_s40_win98_eng.pdf



Alternatively, you could purchase a Secure Digital Card Reader that is compatible with Windows 98/SE. Secure Digital Card Readers can be purchase from most photo & electronic stores.

Hope this helps,



Info_Man
Attached Images
 
Info_Man is offline   Reply With Quote
Old Jan 12, 2005, 6:08 AM   #8
Junior Member
 
Join Date: Jan 2005
Posts: 1
Default

Info-man, I tried your solution and it works fine with my Optio S40 on my Windows 98 PC !Many thanks ! Max.
Max64 is offline   Reply With Quote
Old Jan 13, 2005, 8:46 AM   #9
Member
 
Info_Man's Avatar
 
Join Date: Jan 2005
Posts: 36
Default

Not a problem.

Glad it worked out for you.



Info_Man
Info_Man is offline   Reply With Quote
Old Jan 17, 2005, 11:05 PM   #10
Junior Member
 
Join Date: Jan 2005
Posts: 1
Default

Info-man, Thanks so much for your help. Your solution worked perfectly on my neighbour's PC running Windows 98 . The instructions were very clear and easy to follow. Thanks again. You enhanced my reputation as the local expert, and saved my neighbours lots of hassles with their Christmas present. Regards from New Zealand
Sandra_N is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:30 PM.