Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Sep 13, 2005, 9:56 PM   #11
Junior Member
 
Join Date: Sep 2005
Posts: 5
Default

Can you please tell me where I can find "fwdc110p.bin" to flash my Optio S? I just started having the A90 error come up last week while on vacation. That was NOT COOL considering I was atop the CN tower in Toronto and I could see 50 miles in every direction - but couldn't capture it!
nj_starman is offline   Reply With Quote
Old Sep 14, 2005, 3:04 PM   #12
Junior Member
 
Join Date: Sep 2005
Posts: 5
Default

I answered my own question. I have the file, however, holding menu+power asks me update. I say yes, and after 5 seconds I get an error. Now what?
nj_starman is offline   Reply With Quote
Old Sep 14, 2005, 4:04 PM   #13
Junior Member
 
Join Date: Sep 2005
Posts: 5
Default

philter wrote:
Quote:

One thing I did do in my playing-around was I went into the Secret Menu (The Secret Menu was still working even though I was getting A90), and I played around with some of the Erase/Write/Test/Format options in the Rom Update Menu. I don't know if this led to my successful prom burning, or if it was the full battery.
What is the SECRET MENU?
nj_starman is offline   Reply With Quote
Old Sep 14, 2005, 7:12 PM   #14
Junior Member
 
Join Date: Sep 2005
Posts: 2
Default

Hi nj_starman

where did you find the fwdc110p.bin file ? I have the same problem
you do.

n2ubn
n2ubn is offline   Reply With Quote
Old Sep 16, 2005, 2:05 PM   #15
Junior Member
 
Join Date: Sep 2005
Posts: 4
Default

ALLELUYIAH ! PROBLEM SOLVED !!!

OK Guys...After fidgitting for hours on this with the bits & pieces on this forum & on others...here's how I got it to finally work:

A- I have a Pentax Opio S hence I had to get the "fwdc110p.bin" file here:

http://www.pentax.de/mediapool/attachments/photo/100/104/46139/fwdc110p.zip

Optio S4, S4i & S5i shall use another file. Don't really know for S4 but for S4i & S5i, there on the Pentax customer service website at:

http://www.pentaximaging.com/custome...mware?sfFlag=f

B-Drop this file on your SD Card at the root directory (same level as DCIM folder) or as described by the following link and then close your camera to OFF:

http://www.pentaximaging.com/custome...re?firmId=1020

Attention: Do not load this file yet onto the camera i.e. the menu+power on procedure, follow step C first...

C- Open the now infamous "Secret Menu" in order to re-initialize your camera prior to re-installing the new firm ware:

Simultaneously press MENU + Flash symbol button+ Power ON...a white screen with data written in black should show.

Then a sequence of buttons must be pressed: 2 times the focus button (flower, mountain, MF symbols button) followed by 2togglesto the Right of the "OK" button...then press MENU once and voilĂ*...ze Secret Menuappears !

Using the down toggle of the OK button, go to "SYSTEM INITIAL" and press OK. Press another OK to re-initialize your camera.

Once this has been completed, turn your camera off.

D- Load the firm ware by opening your camera with the MENU+Power ON procedure...finallythis should be posting "Complete" after the "Loading" message, instead of the "Error!" that we initially kept on having.

Your camera should be working perfectly ! Only thing, is that you will have to redo your personal settings on it from scratch...but hey, this is much better than to wait for months to get your camera back from Pentax and save that money for your next photogenic trip!

Cheers,

Phil

Optio S in-an-Altoids box
PhĂ©lin is offline   Reply With Quote
Old Sep 16, 2005, 7:19 PM   #16
Junior Member
 
Join Date: Sep 2005
Posts: 13
Default

i have the Optio S5i.
If i press menu+power on and i want to update the firmware, i get the
"ERROR" message after a while...
And i have tried exactly like you said:
Menu+Flash button + Power on, but nothing...
no white screen.
Insted i get a colour screen:
Initilal setting, date, time, language,
exactly like i was just pressed only the
power on button.

so the problem is that i cannot enter the infamous "Secret Menu".

please help me !!!
RETrACE is offline   Reply With Quote
Old Sep 17, 2005, 10:12 AM   #17
Junior Member
 
Join Date: Sep 2005
Posts: 2
Default

:-) Hi Phélin,

I did it as you have written! IT WORKS!! Pentax wanted 160 € for it.
Thanks!!
mounty
mounty is offline   Reply With Quote
Old Sep 17, 2005, 10:59 AM   #18
Junior Member
 
Join Date: Sep 2005
Posts: 13
Default

Phélin, can you pls help me ??????

I cannot enter the secret menu on my Optio S5i !!!
I do not see any white screen.
if i press MENU+FLASH+POWER ON it's like
i was just pressing POWER ON.


Maybe for the Optio S5i is another way to enter the secret menu...
Attached Images
 
RETrACE is offline   Reply With Quote
Old Sep 18, 2005, 3:45 PM   #19
Junior Member
 
Join Date: Sep 2005
Posts: 4
Default

Sorry RETrACE,

Don't own a S5i...thought that the "secret menu" sequencewas the same throughout the hole Optio S line...it is obviously not ! My internet source for this only mentioned this one, it didn't specify the model, although the problem topic was on an Optio S.

Try using other buttons to make adifferent sequence...you might accidently find it this way !

At least you now know what you should be looking for !

Good luck !
PhĂ©lin is offline   Reply With Quote
Old Sep 19, 2005, 6:57 AM   #20
Junior Member
 
Join Date: Sep 2005
Posts: 13
Default

Thanks Phélin, but i have already tryed many
sequences of buttons, and nothing. I am still working on this.
if nobody knows how to enter the secret menu on a OPtio S5I, just have to work it on my own...
:sad:
RETrACE is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:05 AM.