Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Oct 23, 2005, 12:19 PM   #31
Junior Member
 
Join Date: Sep 2005
Posts: 4
Default

Yeah...in fact maybe we should start a survey on exactely when this problem occured on each of our Option S units, just to know if this is truly a programmed defect to ensure Pentax aftermarket revenues (knowing the $160 + more that some of you were asked to pay).

My A90 problem occured exactely 2 years and just abouta few weeks after I first initiated and set-up the camera, summer 2003.
Phélin is offline   Reply With Quote
Old Oct 23, 2005, 12:43 PM   #32
Junior Member
 
Join Date: Aug 2005
Posts: 3
Default

Well, my Optio S was bought on Aug 15, 2003, first used on Aug 24, 2003 and got the A90 error on Aug 27, 2005. Pretty neat timing for Pentax indeed. Never had problems before with the camera and never had problems since Phelin's miraculous repair trick.
What about the others? Is it that people just start searching the internet for help when the guarantee is void or does this error never appear in the first 2 years!?


snoopy is offline   Reply With Quote
Old Oct 24, 2005, 8:41 AM   #33
Junior Member
 
Join Date: Oct 2005
Posts: 4
Default

My error occurred 2 yrs and 3 months after I got the camera. I have attempted Phelin's solution and appear to be in the same situation as Lucagi & kkwong. A90 is still there :-(
navic99 is offline   Reply With Quote
Old Oct 24, 2005, 5:31 PM   #34
Junior Member
 
Join Date: Oct 2005
Posts: 4
Default

I got it working using a combination of Philter's and Phelin's methods!!

1) Download the "fwdc110p.bin" file. I placed it everywhere on my SD card. At the root, in DCIM folder, in the next folder below that just to cover all bases.
http://www.pentax.de/mediapool/attachments/photo/100/104/46139/fwdc110p.zip

2) Charge the battery to full; I am really not sure if this necessary, but I did it anyway.

3) With the camera off, turn it on with Power+Menu at same time

4) It will ask if you want to "Program Update" > select "Yes"

5) It will update and say "Complete"

6) Turn it off then back on and reset the language, date, time settings and you are all set!

style="BACKGROUND-COLOR: #000000"


navic99 is offline   Reply With Quote
Old Oct 24, 2005, 11:20 PM   #35
Junior Member
 
Join Date: Sep 2005
Posts: 5
Default

Oh boy... I found the bin file at the link provided (thank you) but now I can't copy it because my camera's card is no longer formatted as per my PC. What should I format? FAT32? Can I manully create the directories and use it?
nj_starman is offline   Reply With Quote
Old Oct 25, 2005, 12:41 AM   #36
Junior Member
 
Join Date: Oct 2005
Posts: 4
Default

Hi Guys,

I have an OPTIO S4 with the same A90 Error after using it for 2 years. The battery started out to work funny. And when it died out after shooting a night mode, i got the error. Since then the camera has been worthless for a year. I had it sent to a service center and they told me they have to replace the board for a very large cost.

Does anybody here have the same error on an S4? Does OPTIO S steps work on my S4? I have searched the internet for the .bin file for my model but i cant seem to find any.

Help please.

Thanks.

[email protected]
benleyuy is offline   Reply With Quote
Old Oct 25, 2005, 12:41 AM   #37
Junior Member
 
Join Date: Oct 2005
Posts: 4
Default

Hi Guys,

I have an OPTIO S4 with the same A90 Error after using it for 2 years. The battery started out to work funny. And when it died out after shooting a night mode, i got the error. Since then the camera has been worthless for a year. I had it sent to a service center and they told me they have to replace the board for a very large cost.

Does anybody here have the same error on an S4? Does OPTIO S steps work on my S4? I have searched the internet for the .bin file for my model but i cant seem to find any.

Help please.

Thanks.

[email protected]
benleyuy is offline   Reply With Quote
Old Oct 25, 2005, 7:12 AM   #38
Junior Member
 
Join Date: Oct 2005
Posts: 1
Default

Wow this just made my day. I too have a pentax S camera that has been on lock down with this stupid ass A90 screen. I cant believe I found this save the fact I looked online for over 5 hours. I havent made the attempt yet to update but I will later today and cant fukin wait. Why does pentax do this? O ya its all about corporate profits. Hey Phelin , that is some good stuff you have posted here. I am going to make several copies from this site maybe and lay them around several forums for my family and freinds in America. I am SO stoked! Yall have a good one



-i will commnicate very shortly as to the final effects and possibly anything i say that will help future innocent victims of this BLACK A90 SCREEN OF DEATH! Yall have a good day then.
niknac is offline   Reply With Quote
Old Oct 26, 2005, 10:49 AM   #39
Junior Member
 
Join Date: Oct 2005
Posts: 2
Default

There seems to be numerous amounts of Pentax cameras with the same problem! I experienced the error A90 on my optio S in July, right in the middle of a vacation. Pentax wants $300 for repairs, or they are offering a refurbished camera for $180! Do they think I would actually give them my camera to resell, and fork out $180 for another camera that will probably break down in the very near future?

It seems that Pentax is scamming their customers. My camera had the error A90 apear afteronly1 1/2 years, following the expiry of the year warrenty. How convenient...On top of this I have been waiting since the end of August for the return of my camera. With several inquiries, aservice lady there says it wasn't filed properly and has to now flip through original paperwork to find it. We'll see how long this takes now! All I know is that if I don't get some retribution I am NEVER buying a Pentax camera again.

Is there a customer agency we can contact about substandard products? Pentax must be making a fortune off of this! I will probably get my camera back and try to use this secret menu and all of these other tips if I can figure it out!
natsiv is offline   Reply With Quote
Old Oct 26, 2005, 11:18 AM   #40
Junior Member
 
Join Date: Oct 2005
Posts: 3
Default

My Optio S got A90 after 1 year and 10 moths :evil:. I bought it in USA last Xmas.

I tried several times with phelin method but unluckly. then I send it to Pentax service in Italy: 100€ (about 120U$).

What to do?
I'm deciding, but i love my little pentax, so small that is always useful,
even if i already think about a new digital superzoom :|as Canos Is S2 or Sony H1.

Ciao

lucagi



lucagi is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:52 AM.