Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old May 6, 2005, 8:30 PM   #1
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Hi,

I bought a Kingston Elite Pro 512M SD Card for my Optio5i and after inserting it into the camera and turing on the power. The cameraexpand the lens barrel and did nothing for about 30sec before displaying "Memory Card Error" on the LCD.

I then tried the card on my laptop and PDA - I didn't have any problems when reading to writing to the card in either case.

The card is a "high speed" card rated at "x55" (not sure exactly what that means).

http://www.kingston.com/digitalmedia...ro.asp?tabs=ds

Any suggestion on what to try?

Srijuth
srijuth is offline   Reply With Quote
Sponsored Links
Old May 7, 2005, 4:59 AM   #2
Member
 
HappyMac's Avatar
 
Join Date: May 2004
Posts: 57
Default

Try to format the card in the camera menu under settings > formating.
HappyMac is offline   Reply With Quote
Old May 8, 2005, 5:20 AM   #3
Junior Member
 
Join Date: May 2005
Posts: 4
Default


Thanks for the reply. Unfortunatly, I cannot do anything with the camera other than switch it off when it gets the memory error.

Srijuth
srijuth is offline   Reply With Quote
Old May 8, 2005, 1:44 PM   #4
Member
 
HappyMac's Avatar
 
Join Date: May 2004
Posts: 57
Default

It could be, that your new card is formated FAT32 for PDAs, whereas most cameras (including Pentax) only read FAT16. You can try to reformat it FAT16 on your PC. If this does not work, give it back!
HappyMac is offline   Reply With Quote
Old May 10, 2005, 9:08 AM   #5
Junior Member
 
Join Date: May 2005
Posts: 4
Default

I tried the FAT16 as well with no sucess. It must be something to do with the card. I am sending it back (the SD Card).

Thanks

Srijuth
srijuth is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:50 AM.