Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Dec 29, 2005, 1:06 PM   #1
Junior Member
 
Join Date: Dec 2005
Posts: 3
Default

I've just been given a Pentax Optio 33LF for Christmas. My mother's had it for a year and a bit but never used it, aside from snapping a few pics around the house on the internal memory card. On that (the internal card) all seems to work fine.

I inserted a brand new 256MB SD memory card. Carefully following the instructions, I tried to format it. I took this through to the point where my camera LCD said it was 'formatting' and then *poof* the screen went black and my camera turned itself off.

I tried it several times. I tried it with a new 16MB SD card, in case the 256MB had been too big? Yet all to no avail.

Can anyone possibly tell me what's wrong, and what I can do to make my camera format and successfully use a SD card!

Thanks.
Leoba is offline   Reply With Quote
Sponsored Links
Old Dec 29, 2005, 3:05 PM   #2
Junior Member
 
Join Date: Dec 2005
Posts: 7
Default

It may be because the card is not compatible with the camera. Try checking that it runs on SD, otherwise it may be your camera card slot which has gone wrong.
-- The Story of the problem --

The camera starts reading from the card, but then the card reacts with the camera, and the camera shuts down either to prevent a problem, or just because while reading the card the card chip is not working, and decides to turn the camera off.

I am not sure, its worth buying a new card, otherwise just give it to the shop and ask the sales assistant.

Thank you,
Shock260.
Shock260 is offline   Reply With Quote
Old Jan 1, 2006, 10:39 AM   #3
Junior Member
 
Join Date: Dec 2005
Posts: 3
Default

Thanks for replying.

I have tried two different cards, two different brands (one Toshiba, the other from Jessops), so I suspect a trip to the camera will have to be in order.

What a nuisance!
Leoba is offline   Reply With Quote
Old Jan 1, 2006, 11:37 AM   #4
Senior Member
 
mtclimber's Avatar
 
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143
Default

Leoba-

The Pentax 33LF is an older digicam. Check the batteries first, then use a 128mb SD chip/card or smaller. The digicam may be limited to a max size card of 128mb.

MT
mtclimber is offline   Reply With Quote
Old Jan 3, 2006, 7:12 AM   #5
Junior Member
 
Join Date: Dec 2005
Posts: 3
Default

That's what I've done. Using a brand new CR-V3 battery, I tried installing a 16mb SD card.

That surely can't be too large?



Leoba is offline   Reply With Quote
Old Apr 23, 2006, 10:58 PM   #6
Junior Member
 
Join Date: Apr 2006
Posts: 2
Default

I have an Optio33Lf and also had trouble formatting a 1GB memory card. I stuck the memory card in a card reader on my computer, formatted it on my computer, and it works just fine. So if you can get access to a computer that can take memory cards you might want to give that a try.
iam425 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:24 AM.