Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Jun 1, 2006, 7:34 PM   #1
Junior Member
 
Join Date: Jun 2006
Posts: 1
Default

I've been very happy with my Optio 330 for quite a few years, with no problems.

The other day, I was trying to take a picture, and it said, "Memory Card Full." I didn't think it was, but I tried deleting some shots, anyway. Then when I tried to take a picture, it said, "Memory Card Error." I was worried about losing my pictures, so I stopped messing with it until I could get home and put my card into the card reader. My pictures were all still there, so I emptied them onto my PC and then tried to use the card again.


This time the camera said, "Memory Card not formatted." I went to the menu and chose "Format Card." Then it said, "Formatting..." following immediately by "Memory Card not formatted."


I tried this with 3 different cards (a 128 CF, a 256 CF, and a 512 CF), and it was all the same. Everything else on the camera is perfect--but as it has no internal memory, this is a pretty big problem!

Has anyone else has this problem? Is it fixable?

Thanks,

Sophy
sophy26 is offline   Reply With Quote
Sponsored Links
Old Aug 13, 2006, 6:59 PM   #2
Junior Member
 
Join Date: Aug 2006
Posts: 3
Default

I have the same problem with the S50 , I can't seem to get any help with this. Hopefully someone here can help us!!
micca is offline   Reply With Quote
Old Aug 14, 2006, 1:25 AM   #3
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

What do you mean by the same problem? Errors?

Can you format the card via the camera's menus for format?

That's usually the first step if you can't get a card to work or you're getting errors of any type.

As a rule, I always format a card using a camera's menus for format prior to every use, no exceptions. That insures that I always start out with a fresh File Allocation Table, just the way the camera expects it, since the camera is performing the format.

The most common problem is a corrupted FAT, and a format usually fixes it (using the camera's menu choice for that purpose). If you can't format the card (problem the Original Poster in this thread had with multiple cards), then we have to look at the possibilty of something else being wrong.

Usually that something else is a defective card. In the case of the Original Poster, multiple cards were tried (so it's more likely a camera problem). The OP's camera used CompactFlash. So, I'd probably look for a bent pin in the card slot.

Your S50 uses Secure Digital. So, that's not the probem with it.

Give more details on what is going wrong and if you can format the card or not with the camera's menu choice for format. You'll see it shown at the bottom of this page in it's review here:

http://www.steves-digicams.com/2004_...ios50_pg4.html


JimC is offline   Reply With Quote
Old Aug 14, 2006, 2:56 AM   #4
Junior Member
 
Join Date: Aug 2006
Posts: 3
Default

I tried formatting the cards thru the camera's menu & that's when "card not formatted" came up on the camera. I tried several times w/the same results, so I went & purchased a new SD 1GB card. First message was "Memory card error", then I was able to get into the menu (all on camera); tried to format the brand new card-same results- camera said "formating", then "card not formatted". Once again, I tried several more times with no luck.

I've tried several cards that had previously worked just fine, then I tried with a brand new card w/the same results. Memory card error, then card not formatted(after going thru camera's menu steps to format).

Memeory card error comes up immediately after I turn the camera on , LCD is blank & can not take picture. After a few minutes, then I can access the menu screen & attempt to format, says it's formating.....card not formatted.

I hope I've explained clearly, I'm so use to keeping posts/e-mails, short & sweet ( so to speak)!

Thank you
micca is offline   Reply With Quote
Old Aug 14, 2006, 9:50 AM   #5
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Some camera models can be picky about memory cards, and you do see compatiblity issues pop up more often with Secure Digital.

Pentax says this about the S50:

"While Pentax does not guarantee compatibility with any particular manufacturer or model, we have seen consistent compatibility with SD cards from Panasonic ( 16 / 32 / 64 / 128 / 256 / 512MB,1GB), SanDisk ( 16 / 32 / 64 / 128 / 256 / 512MB,1GB), and Toshiba (16 / 32 / 64 / 128 / 256 / 512MB)."

You may want to try formatting the card using a card reader and see if it can see it then. But, make sure to select FAT as the file system type from the drop down list. Otherwiise, Windows will use a 32 bit FAT by default which is not compatible with your camera.

Do you have a smaller card you could try in it (512mb or less).


JimC is offline   Reply With Quote
Old Aug 14, 2006, 8:06 PM   #6
Junior Member
 
Join Date: Aug 2006
Posts: 3
Default

yes, I tried both 128MB & 64MB with the same results.
I just wanted to say thanks for your time & help, it's deeply appreciated

Thank you

Laura
micca is offline   Reply With Quote
Old Aug 19, 2012, 1:50 PM   #7
Junior Member
 
Join Date: Aug 2012
Posts: 1
Default

I shot many pics on a SANDISK EXTREME PRO 16GB CARD. Suddenly the camera said "CARD NOT FORMATTED, FORMAT CARD". The camera refuses to display any pics.
In an earlier forum you suggested to go to MY COMPUTER>>>RIGHT CLICK ON PROPERTIES>>SEE IF CARD IS RECOGNIZED. In my case it is recognized there. Now what should I do? FORMAT THE CARD THAT IS PLUGGED IN VIA THE CARD READER?
How should I format it? Please let me know the steps. Thank You.
alemap is offline   Reply With Quote
Old Aug 19, 2012, 2:20 PM   #8
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

alemap:

Edited.... I just realized you were talking about a model using CompactFlash cards.

Format it as FAT32 if using Windows.

JimC is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:28 AM.