Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Reply
 
Thread Tools Search this Thread
Old Jun 27, 2006, 4:36 PM   #1
Junior Member
 
Join Date: Jun 2006
Posts: 2
Default



hi,

Recently on a trip i was using my pentax optio s and i wanted to conserve battery life; so i turned off the display, but after taking a few shot i wanted to see the picture and the display wouldn't turn on so i turned off the camera and turned it back on and the display showed a "A90" error. so i downloaded the firmware and tried to installing it in the camera. But after i had reformated the sd card ( i did this with the usb connected with the pc and camera) and tried holding the "menu + flash icon + power button" to get to the "secret menu" the green light surrounding power button just keeps on flashing on and off. The display doesn't show anything the lens doesn't open or do anything, all i get it the light flashing. i've tried removing the battery and putting the battery fully charged back in and the light still flash, i've tried holding on the power button for a while and nothing happen. my camera is about 4 years old and i've dropped it once about 4 or 5 months after i bought it but it worked fine without a problem for about 3 1/2 years. Have any one experience this problem or have a solution or could tell me what's wrong with it? thanks in advance!

magic1010321 is offline   Reply With Quote
Sponsored Links
Old Jun 27, 2006, 6:41 PM   #2
Junior Member
 
Join Date: Jun 2006
Posts: 2
Default

Never i fixed it! haha after 3 days of trying to figure it out i finally got it....what i did was remove the memory card and the A90 error showed up again and i was able to turn of the camera with out the green light flashing and i followed the direction to fix the A90 error and it worked! i would say i would i will never buy a pentax again unless it super super super cheap but i gotta say i will NEVER EVER BUY it again cause their customer service suck!
magic1010321 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:59 PM.