Go Back   Steve's Digicams Forums > Post Your Photos > Photo Critiques

Reply
 
Thread Tools Search this Thread
Old Mar 7, 2007, 11:17 PM   #1
Senior Member
 
Imacer's Avatar
 
Join Date: Jan 2004
Location: Juneau, Alaska
Posts: 474
Default


Imacer is offline   Reply With Quote
Sponsored Links
Old Mar 7, 2007, 11:18 PM   #2
Senior Member
 
Illuminati's Avatar
 
Join Date: May 2006
Location: California, USA
Posts: 583
Default

Not sure if it's just me, but I'm not seeing any photo.
Illuminati is offline   Reply With Quote
Old Mar 7, 2007, 11:34 PM   #3
Senior Member
 
Join Date: Feb 2007
Posts: 1,306
Default

Ok Imacer, this is your 1st post.

now press the reply "button" and under "browse", navigate to tthe picture you wish to post then press "send" button as usual.We are waiting
mcliu is offline   Reply With Quote
Old Mar 7, 2007, 11:37 PM   #4
Senior Member
 
Imacer's Avatar
 
Join Date: Jan 2004
Location: Juneau, Alaska
Posts: 474
Default

Please give some feedback to improve my photo. Thanks.
Attached Images
 
Imacer is offline   Reply With Quote
Old Mar 7, 2007, 11:40 PM   #5
Senior Member
 
Imacer's Avatar
 
Join Date: Jan 2004
Location: Juneau, Alaska
Posts: 474
Default

Maybe better.
Attached Images
 
Imacer is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:49 AM.