Go Back   Steve's Digicams Forums > Post Your Photos > Photo Critiques

Reply
 
Thread Tools Search this Thread
Old Nov 17, 2010, 12:27 PM   #1
Senior Member
 
Mark2009's Avatar
 
Join Date: Jan 2010
Location: USA
Posts: 275
Default Car meets Tree

This just happened down the street, we have 50+ MPH winds going here in NY! No one was injured.
Canon Xsi, 85mm....
Attached Images
 

Last edited by Mark2009; Nov 17, 2010 at 12:44 PM.
Mark2009 is offline   Reply With Quote
Sponsored Links
Old Nov 17, 2010, 12:29 PM   #2
Senior Member
 
Join Date: Sep 2010
Posts: 268
Default

Wow, I hope everybody is ok!
Green Eyed Stranger is offline   Reply With Quote
Old Nov 17, 2010, 12:37 PM   #3
Senior Member
 
Wizzard0003's Avatar
 
Join Date: Oct 2010
Location: Aberdeen, WA USA
Posts: 1,085
Default

OUCH...!!!

Hope no one was hurt and the owner's got "Falling Tree" insurance...!

We have severe wind storms here every winter... Last year we had one with gusts
reaching over 120mph...!

I thought for sure my windows were going to end up in my lap...

Good capture and keep on the lookout for flying debris...
Wizzard0003 is offline   Reply With Quote
Old Nov 17, 2010, 12:38 PM   #4
Senior Member
 
zombz's Avatar
 
Join Date: Nov 2010
Location: wolcott NY
Posts: 437
Default

yea im also in ny and the winds r picking up where im at and hope everyone is ok
zombz is offline   Reply With Quote
Old Nov 17, 2010, 12:57 PM   #5
Senior Member
 
Ordo's Avatar
 
Join Date: Jul 2009
Location: BsAs
Posts: 3,452
Default

Sad accident. Good document.
Ordo is offline   Reply With Quote
Old Nov 17, 2010, 1:09 PM   #6
Senior Member
 
Wizzard0003's Avatar
 
Join Date: Oct 2010
Location: Aberdeen, WA USA
Posts: 1,085
Default

YIKES...!

While I've been posting my internet went down for a few minutes, the wind is blowing,
the power keeps flickering and rain is beating against my windows...!

What's going on here, I'm at least 3600 miles from New York on the other side of
the Continent...!?

Are you guys sending your bad weather my way...?
Wizzard0003 is offline   Reply With Quote
Old Nov 17, 2010, 1:19 PM   #7
Senior Member
 
Mark2009's Avatar
 
Join Date: Jan 2010
Location: USA
Posts: 275
Default

Quote:
Originally Posted by Wizzard0003 View Post
YIKES...!

While I've been posting my internet went down for a few minutes, the wind is blowing,
the power keeps flickering and rain is beating against my windows...!

What's going on here, I'm at least 3600 miles from New York on the other side of
the Continent...!?

Are you guys sending your bad weather my way...?
Global Warming
Mark2009 is offline   Reply With Quote
Old Nov 17, 2010, 1:34 PM   #8
Senior Member
 
Wizzard0003's Avatar
 
Join Date: Oct 2010
Location: Aberdeen, WA USA
Posts: 1,085
Default

Quote:
Originally Posted by Mark2009 View Post
Global Warming
HAAA...!
Wizzard0003 is offline   Reply With Quote
Old Nov 17, 2010, 4:22 PM   #9
Senior Member
 
jerwilhelm's Avatar
 
Join Date: May 2007
Posts: 130
Default

Probably for the best - I had a Ford Probe like that and wished many times a tree would fall on it!!
jerwilhelm is offline   Reply With Quote
Old Nov 18, 2010, 4:58 AM   #10
Senior Member
 
hkmp50's Avatar
 
Join Date: Oct 2010
Location: USA
Posts: 1,370
Default

If I was to critique this, and knew anything about what I was saying, I would say it looks just slightly oof to me, and the color looks somehow kind of off, Is this right or is my monitor just not good enough and deceiving me?
Otherwise I would say great reporting, nice after action shot.
Frank

Last edited by hkmp50; Nov 18, 2010 at 5:03 AM.
hkmp50 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:13 AM.