Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Samsung

Reply
 
Thread Tools Search this Thread
Old Aug 1, 2005, 9:34 AM   #1
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

Hi forum , new here and like my samsung camera until yesturday after using it and take good care of her ( camera ) no water , knocing , throwing .When I tryed to power on and get the pictures to PC its not responding its dead tryed new batterys nothing please help

Im afraid service will cost more then new camera any help to save this one

Thank you anyway
Attached Images
 
opaopa is offline   Reply With Quote
Sponsored Links
Old Aug 1, 2005, 9:20 PM   #2
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

please anyone out there knows how to help me

thank you
opaopa is offline   Reply With Quote
Old Aug 4, 2005, 7:30 AM   #3
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

bump ...
opaopa is offline   Reply With Quote
Old Aug 9, 2005, 8:32 AM   #4
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

hoping someone wil help
opaopa is offline   Reply With Quote
Old Oct 16, 2005, 3:50 PM   #5
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

that was a very good camera to bad I could not fix it , just got Canon A510 not bad either to bad nobody could help but thx for reading it I must be the only one with this problem
Attached Images
 
opaopa is offline   Reply With Quote
Old Nov 9, 2005, 3:06 PM   #6
Junior Member
 
Join Date: Nov 2005
Posts: 1
Default

Hey OPAOPA,

I've got a 301 that could use a few parts, Interested in selling yours? The part where the camera screws on to a tripod broke loose and twisted taking out a printed circuit ribbon. Anyways, email me at [email protected], Thanks, Mike
inconsequential is offline   Reply With Quote
Old Jul 19, 2006, 2:20 PM   #7
Junior Member
 
Join Date: Jul 2006
Posts: 1
Default

i got the 301 camera and i replaced the batteries with new ones and everything. nothing fixes it. i am in the process of taking it apart and trying to find a better solution to the problem. i lost my dc power cord for the camera but i am still gonna break the camera down and try to find the problem. my camera will come on for around 2 secs and say low battery and then power off i have tried rechargable batterys and everything. i will get back to you when i find a solution to this.
gras is offline   Reply With Quote
Old Oct 1, 2006, 12:32 AM   #8
Junior Member
 
Join Date: Sep 2006
Posts: 1
Default

gras wrote:
Quote:
i got the 301 camera and i replaced the batteries with new ones and everything. nothing fixes it. i am in the process of taking it apart and trying to find a better solution to the problem. i lost my dc power cord for the camera but i am still gonna break the camera down and try to find the problem. my camera will come on for around 2 secs and say low battery and then power off i have tried rechargable batterys and everything. i will get back to you when i find a solution to this.
ruli is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:24 PM.