Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Samsung

Reply
 
Thread Tools Search this Thread
Old Apr 6, 2006, 11:06 AM   #1
Junior Member
 
Join Date: Apr 2006
Posts: 3
Default

This camera is about 1 year old. It started intermitently not powering up. When I push the power button it show the logo on the LCD briefly and a red light flashes on the back. Then it shuts down. When push the button on the back to review pics it will let me do that. I just can't take pictures. Any idea what may be wrong? I imagine it is junk like most other electronics that fail.

Thanks
ebby69k is offline   Reply With Quote
Sponsored Links
Old Apr 9, 2006, 4:59 PM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Did you try replacing the batteries?

JimC is offline   Reply With Quote
Old Apr 27, 2006, 1:18 AM   #3
Junior Member
 
Join Date: Apr 2006
Posts: 1
Default

that same exact thing is happening to me and i have had the camera for about the same time. i have changed the batteries a hundred times now, and nothing. if you find out anything, it would be helpful!
thatcheergurl is offline   Reply With Quote
Old May 3, 2006, 1:10 PM   #4
Junior Member
 
Join Date: Apr 2006
Posts: 3
Default

Yes I did change the batteries.
ebby69k is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:47 AM.