Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sanyo

Reply
 
Thread Tools Search this Thread
Old Nov 7, 2007, 8:16 AM   #1
Junior Member
 
Join Date: Nov 2007
Posts: 25
Default

Dear all, could you help me with a problem of codec conversion? I'm very happy with my hd1000, but my p4 3.0 computer is a bit too slow playing back the original 1080i h.264 files. I get around 24 fps at most. 720p is fine. So I used Vegas 8 pro to convert the 1080ifiles from h.264 to mpeg-2. After the conversionI can play themvery fluidly. But nowthe videos have very bad shadows, especially when they were paused.

I understand it might be the problem of interlacing, but when I play the original 1080i files, they have no such ghosting or shadows since I have set the coreavc codec with software de-interlacing.

Why the difference? How can I get rid of the terrible shadows? I tried every possible output option in vegas, but got the same result. Could you tell me your successful output setup? I'm really going crazy about this.

Thanks in advance!
dongdongliushui is offline   Reply With Quote
Sponsored Links
Old Nov 7, 2007, 8:56 AM   #2
Senior Member
 
Caelum's Avatar
 
Join Date: Sep 2005
Posts: 1,030
Default

What bit-rate did you encode the MPEG-2 video at? Remember that MPEG-2 is at least half (or less) as efficient as AVC, therefore you would need to at least double the bit-rate using MPEG-2 to preserve the quality of AVC. Sotry using abit-rate of at least 25Mbpsto encodeMPEG-2 1080i video.
Caelum is offline   Reply With Quote
Old Nov 7, 2007, 7:50 PM   #3
Junior Member
 
Join Date: Nov 2007
Posts: 25
Default

Thanks, Caelum. I checked the bit rate, and it's 25m/s. I used both the blueray mpeg-2 and hdv output scheme. Same result.

I guess it might be the problem of the coreavc codec
or player I'm using. Does Vegas use its own h.264 codec to decode and encode files?
dongdongliushui is offline   Reply With Quote
Old Nov 7, 2007, 11:20 PM   #4
Senior Member
 
Caelum's Avatar
 
Join Date: Sep 2005
Posts: 1,030
Default

Probablya problem with your MPEG-2 codec / playback software then. What MPEG-2 codec are you using (Windows does not come with a built-inMPEG-2 codec) and with what playback software? CoreAVC would not play a role in your problem as Vegas has it's own AVC codec (Mainconcept) and CoreAVCwill not decode MPEG-2 for playback.
Caelum is offline   Reply With Quote
Old Nov 8, 2007, 6:15 AM   #5
Junior Member
 
Join Date: Nov 2007
Posts: 25
Default

Caelum, I have mpeg-2 codec of nvidia, gabest, ulead studio. What mpeg-2 codec are you using for playback?
dongdongliushui is offline   Reply With Quote
Old Nov 8, 2007, 8:08 AM   #6
Senior Member
 
Caelum's Avatar
 
Join Date: Sep 2005
Posts: 1,030
Default

I'm using the Mainconcept MPEG codecto handleMPEG-2 for all my media players. I don't know, if you've tried multiple MPEG-2 codecs, maybe there is something else going wrong. Try enabling de-interlacing for the codec you are using (Mainconcept'scan do this), that could be part of the issue. Or, perhaps it's a combination of your codec, media player and not having a large enough screen resolution (try at least 1920x1080). Hopefully someone else with more experience handling MPEG-2 1080i HD can chime in. (By the way, "HDV" = 1440x1080 on my version of Vegas (6.0d), theylabel 1920x1080 "HD").
Caelum is offline   Reply With Quote
Old Nov 8, 2007, 8:49 AM   #7
Junior Member
 
Join Date: Nov 2007
Posts: 25
Default

Yes, Caelum! With your help I finally figured it out. It's because of the de-interlacing method. With gabest mpeg-2 decoder there is 5 de-interlacing options: auto, bob, weave, blend, field shift. Only "bob" works without any shadow! I don't know why but that's the trick. Maybe someone can elaborate on these jargons a bit? Anyway ifanyone is experiencing the same problem as mine, just try "bob"!
dongdongliushui is offline   Reply With Quote
Old Nov 8, 2007, 9:20 AM   #8
Senior Member
 
Caelum's Avatar
 
Join Date: Sep 2005
Posts: 1,030
Default

Good to hear. I think "bob" makes full frames out of each field (perhaps using interpolation) whereas the other methods try tomixboth fields into each frame.
Caelum is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:21 AM.