Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sanyo

Reply
 
Thread Tools Search this Thread
Old Mar 25, 2009, 6:53 AM   #1
Junior Member
 
Join Date: Mar 2009
Posts: 15
Default

Hello people, I've scoured the net to find answers regarding my problem, but unfortunately haven't found what I'm looking for.

I am a total n00b to this sort of stuff, so I apologise if this has all been said before.

I had initially recorded videos in the full HD mode to see how good the video quality was. When I transfered the videos to my computer they would only display the first frame of the video but play the whole audio (Using various players including VLC). In Vegas 7 it only plays the audio track as well. The exact same thing happens when I convert it from mp4 to avi.

When I switch down to the lower setting of 1280x720 60fps, it plays the video but very jerky.

After having played about a bit more, I realise the highest res that the computer will play smoothly is 1280x720 30fps.

Does this mean that my computer doesn't have enough power to play the high end stuff? Or is it a matter of downloading codecs? I'm quite prepared to buy more RAM/graphics card etc. if needed so I can play this material.

I'm on a Dell Dimension 5150.
Intel Pentium 4 CPU 3.4GHz with 1GB RAM.

Any assistance is much appreciated.

Graeme.
dis0rientati0n is offline   Reply With Quote
Sponsored Links
Old Mar 25, 2009, 7:19 AM   #2
Junior Member
 
Join Date: Mar 2009
Posts: 15
Default

And...

(this will show my complete lack of knowledge)

What is the difference between the different modes?

- (Full-HD) 1920 x 1080, 60fps
- (Full-SHQ) 1920 x 1080, 30fps
- (HD-HR) 1280 x 720, 60fps
- (HD-SQH) 1280 x 720, 30fps

I understand that the Full-HD is interlaced and 60 fields per second where as Full SHQ is progressive at 30 frames per second.

Is the difference between Full HD and HD-HR just the dimensions of the image, hence a larger file size?
dis0rientati0n is offline   Reply With Quote
Old Mar 25, 2009, 9:01 PM   #3
Senior Member
 
Join Date: Aug 2008
Posts: 224
Default

First off I would say stay away from interlaced video (fields/sec) unless you are playing directly to a TV through the docking station.

The sizes are pretty much self explanatory. If you are taking movies with a lot of movement I would use the 720p 60 frames/sec.

You computer may now be powerful enough to play the videos or you might just have the wrong video codecs installed. I have found this program "Super" able to playback all of my videos the smoothest. VLC's latest build seems to have problems on my computer as it doesn't play back my videos as smooth as Windows Media Classic.

You could try to download a codec pack called K-Lite codec pack standard. First though I would try Super to see if it is your computers power or the playback program.

Here is the webpage for Super, it can't hurt to try it to see if it makes any difference.

http://www.erightsoft.com/SUPER.html
relate2 is offline   Reply With Quote
Old Mar 25, 2009, 10:22 PM   #4
Senior Member
 
Join Date: Jan 2006
Posts: 1,092
Default

Your computer is dated and now considered an "E-machine"


Minimum spec for smooth playback and video editiong is recommended by others to be comfortable for 720p is:

at least
amd 6400 dual core or intel equiv.
2gb ddr 800 memory
3gb/sec sata drives
8800gt with pci express slot and at least 512mb onboard graphics memory.

If you want to play back [email protected], you need software that can actually utilize the GPU graphics chip for decoding.

Most software or video editing software is not optimized to utilize the power of the GPU. Most software rely on the capacity of your current rig to produce viewable content but this is not the case anymore. New and accelerated hardware and optimized software is needed for viewing HD content on the pc. Without these, you are stuck with a slideshow.

In your case, I recommend you find an gpu accelerated software player.
http://forums.steves-digicams.com/fo...mp;forum_id=27

Vegas video is unable to smoothly playback such content since it is not hardware accelerated enabled for video playback of such content.

when you update your pc, make sure all or most components related to video playback is HDMI/HDCP specifically your graphics card which needs to be at least a 8800gt and a monitor that has hdmi/hdcp specifically the HP w2408 monitor.

I am mentioning these blueray playback requires this and incase you wonder of other issues so i kinda nailed it for you.

avchd playback on my linux box is a bit tedious especially the [email protected] but converted to xvid plays fine. and my spec is just what I recommend and posted. Anything higher than my machine spec is perfect for [email protected] In fact, my machine is already dated.
Cresho is offline   Reply With Quote
Old Mar 26, 2009, 2:32 AM   #5
Senior Member
 
Join Date: Jan 2006
Posts: 1,092
Default

Cresho wrote:
Quote:
Your computer is dated and now considered an "E-machine"


Minimum spec for smooth playback and video editiong is recommended by others to be comfortable for 720p is:

at least
amd 6400 dual core or intel equiv.
2gb ddr 800 memory
3gb/sec sata drives
8800gt with pci express slot and at least 512mb onboard graphics memory.

If you want to play back [email protected], you need software that can actually utilize the GPU graphics chip for decoding.

Most software or video editing software is not optimized to utilize the power of the GPU. Most software rely on the capacity of your current rig to produce viewable content but this is not the case anymore. New and accelerated hardware and optimized software is needed for viewing HD content on the pc. Without these, you are stuck with a slideshow.

In your case, I recommend you find an gpu accelerated software player.
http://forums.steves-digicams.com/fo...mp;forum_id=27

Vegas video is unable to smoothly playback such content since it is not hardware accelerated enabled for video playback of such content.

when you update your pc, make sure all or most components related to video playback is HDMI/HDCP specifically your graphics card which needs to be at least a 8800gt and a monitor that has hdmi/hdcp specifically the HP w2408 monitor.

I am mentioning these blueray playback requires this and incase you wonder of other issues so i kinda nailed it for you.

avchd playback on my linux box is a bit tedious especially the [email protected] but converted to xvid plays fine. and my spec is just what I recommend and posted. Anything higher than my machine spec is perfect for [email protected] In fact, my machine is already dated.
Here is an update!

I booted into windowsxp for the first time this year and installed that particular video player with the ffdshow_rev2630_20090122_clsid.exe and used the system monitor to see cpu usage. I had 0 cpu usage. gpu accelerated video is the way of the future.

viewed [email protected] fullspeed, no problems, no video tearing at all. I guess my pc is still worth keeping around.

On the other hand, my linux box freezes video after like 3 seconds using totem. I guess I'll need to try xine or mplayer, or vlc and see what's going on.
Cresho is offline   Reply With Quote
Old Mar 26, 2009, 11:19 AM   #6
Junior Member
 
Join Date: Mar 2009
Posts: 15
Default

Ok, so I ended up ditching the old PC and using the laptop I have from my work. Now it's a really cheap and cheerful Toshiba with not the best graphic card in the world, but as it's only a couple months old, i thought i would give it a whirl.

System Manufacturer TOSHIBA
System Model Satellite A200
System Type X86-based PC
Processor Intel(R) Core(TM)2 Duo CPU T5800 @ 2.00GHz, 2000 Mhz, 2 Core(s), 2
Installed Physical Memory (RAM) 2.00 GB

After downloading codec packages and MPC, I get the 720p files to play. All was good...

Until I attempted the next step:

I am trying to edit with Vegas 7. I can edit the raw mp4 files but the preview is very jumping. I believe this is just how Vegas deals with the Xacti mp4 file from reading about.

I have then used mp4cam2avi to convert into avi format for editing.

Unfort. the avi files then do not work properly in either Virtual Dub or Vegas. They only appear as audio files.

I have downloaded Gspot to find out if there was a codec missing, but it advises me that the codec is installed. The avi files do play in any other player, but just not vegas or vdub.

I thought then there might have been a problem with the avi format I was using. I intially used mp4cam2avi to do the convertion and it has to be said that playing the avi file in VLC etc, there isn't much reduction in the quality of the video.

Anyway, I downloaded Pazera to see if that made any difference. I converted it into a xvid codec avi but the result was horrible. Video looked like it had been taken with a 90's camera phone. When I put it into Sony Vegas though, the same thing happened again. Only the audio shows up on the timeline and there is no video preview.

Is this down to me just lacking raw power or is it a software issue?


Thank you very much for your responses btw.
dis0rientati0n is offline   Reply With Quote
Old Mar 26, 2009, 5:15 PM   #7
Senior Member
 
Join Date: Jan 2006
Posts: 1,092
Default

You Are doing everything correct! you are doing nothing wrong but I have the forumula you seek. The best you can do is use vegas video 7 or 8 as is. Both cannot playback the video in any codec nor in any framerate(just a thought here, maybee you can increase vegas memory usage in prefference but I never tried this and ill give it a whirle tonight). The videos look more like a slideshow and there is no home pc powerfull enough to do all that rendering. Vegas or sony needs to add gpu support for hardware accelerated playback but this isnt going to happen since all rendering and transitions are done software. This is why we see a slideshow and I see it as well. I havent tweaked vegas yet since I barely got my workflow for excellent video conversion and editing for vegas.

The problem with vegas is it does not correctly decode the xacti mp4 files. When I did a side by side comparison of video converted using free software and vegas, free software provided a better look and sharpness and also color. Vegas decodes the mp4 files in a way that you see blocks of colors especially on reds. It looks as if it tries to deinterlace at 5x5 pixles. Really nasty.

my solution was to first convert the 720p to mpg and use that to edit in vegas. If you can get the right balance between compression and reading rate, you can smoothly edit these videos in vegas but this is just a stupid idea since you need to spend lots of time coming up with a command line or setting.

this is the way i throw my videos into vegas

winff->vegas video 7 or 8

winff settings are.

preset name: xacti720p2vegasmpeg
preset labal: xacti 720p 2 vegas mpeg
preset command line: -vcodec mpeg1video -r 59.94 -s 1280x720 -b 20000K -acodec mp2 -ab 320k -ar 48000 -ac 2

I then can output to xvid [email protected] 14000bitrate with mp3 audio 192k stereo 48000.

codecs used are the xvid and also the radium mp3 installer which I have no clue to where it is on the net. This is the only codec installer which allowes vegas 7 and not 8 to output to mp3 audio on windows xp.

WHen I go from my xvid mp3 avi created in vegas to dvd and to get the best possible image, I open the avi in vegas and convert to a lower FPS for mp2 dvd creation. The reason I go through this process is because vegas is the only software I know of that can convert 59.94 fps to 29.97 fps blurring the frames as if it was shot at the low frame rate and not having a software just use every other frame because this causes the imfamous "video flickering" most people here talk about. My videos come out superb as most people already commented. I'm not talking about the shots, I'm talking about the process used. My home videos are fine and You have all these tools available especially virtualdub and deshaker for those nasty home party videos with shake issues. I managed to save quite a few of them with virtualdub.
Cresho is offline   Reply With Quote
Old Mar 27, 2009, 5:30 AM   #8
Junior Member
 
Join Date: Mar 2009
Posts: 15
Default

Cresho, you are indeed a legend.

Converted into mpg and it is now editable (if that is even a word).

The last question is regarding increasing the quality after editing. At the moment, I am only wishing to keep the edited film on the computer, hence no plans of burning to DVD etc.

After i have edited the mpg file in vegas (I'm just talking about putting filters on/ cutting/adding audio track etc), what do you suggest is the best method of improving the look?

I've not tried out Virtualdub yet even though i have downloaded it and am a bit unsure what it's purpose actually is.

Again, sorry for the complete lack of knowledge here, but everyone has to start somewhere, lol.
dis0rientati0n is offline   Reply With Quote
Old Mar 27, 2009, 11:52 AM   #9
Junior Member
 
Join Date: Mar 2009
Posts: 15
Default

So I had an attempt at Deshaker in Vdub today. Again due to my lack of hardware power, it took two hours to "deshake" 30 seconds of footage. Offt.

When it did finish, there was some serious artifacting (is that what you call it) in some diaganol lines. Maybe this was due to the codec I saved it in? (Cinepack something another).

Regarding the deshaking itself, I am very impressed. It has taken a very shakey piece of footage and smoothed it out very effectively. Although I don't understand what the black borders at the top and bottom changing size is all about.

Now if only I can figure out how to make it look less grainy and blocky. :O
dis0rientati0n is offline   Reply With Quote
Old Mar 27, 2009, 3:36 PM   #10
Senior Member
 
Join Date: Jan 2006
Posts: 1,092
Default

dis0rientati0n wrote:
Quote:
Cresho, you are indeed a legend.

Converted into mpg and it is now editable (if that is even a word).

The last question is regarding increasing the quality after editing. At the moment, I am only wishing to keep the edited film on the computer, hence no plans of burning to DVD etc.

After i have edited the mpg file in vegas (I'm just talking about putting filters on/ cutting/adding audio track etc), what do you suggest is the best method of improving the look?

I've not tried out Virtualdub yet even though i have downloaded it and am a bit unsure what it's purpose actually is.

Again, sorry for the complete lack of knowledge here, but everyone has to start somewhere, lol.
Ill share my virtualdub settings in a bit but lets first get you started with the vegas encoding part.

Of course you already know when starting a vegas project before anything, set up your vegas telling it you will be doing your 720p footage.
file->properties:

video tab
width:1280
height:720
field order:none
pixel aspect ratio:1.0 square
output: 0 degrees
framerate:59.94
pixel format:32bit
compositing gama:2.222
full-res rendering: best
motion blur type: gaussian
deinterlace method: none


audio tab
master bus mode:stereo
number buses: 0
sample rate: 48000
bit depth: 16
resample quality: best

ruler tab:
ruler time format:time&frames

click on video tab name template
template: [email protected]
tick "start all new project with these settings and now click on save "floppy symbol"up on top where you entered "[email protected]" apply and okay at bottom.

now you can dump your videos into it.
------------------------------------------------------------------------------------
when you are done, you can export it to anything you want but I use xvid and mp3. Your system is guarantee not to export to mp3 at all. the two codecs I use are....
Xvid-1.2.1-04122008.exe
ra-codec12.zip

There are no other codecs on the planet which allowes vegas video to encode into mp3 audio than ra-codec12.zip.

now for my settings on how I render my video when done.
click on file->render as
in the pop up window, click on "save as type" avi
now click on "custom" that is next to template:

create a new profile called xacti720p59.94xvidmp3

project tab->video rending:best
in video tab
tick: include video
frame size: HDV 720
framerate: 59.940
field order: none
Pxel aspect ratio: 1.0000
video format: XviD MPEG-4 Codec and click configure
profile:unrestricted
encoding type:single pass
target bitrate:14000 (keep an eye on this one..it is shared through programs and can change automatically and I don't think the template manager manages these values. so double check this and quality settings before rendering)
click on target bitrate to change to target quantizer and put 1 for quality.
tick "create an opendml avi compatible file."

now click on audio tab
include audio
audio format: make sure you use the first twin called "MPEG Layer-3"
attributes: 256 48000 stereo

click on save template ontop with that floppy symbol and okay it.









Ill talk about virtualdub and deshaker later. Ill also share all my templetes for deshaking. I'll also share on how to improve video render playback in vegas's monitor.
Cresho is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:53 PM.