Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sanyo

Reply
 
Thread Tools Search this Thread
Old Aug 24, 2009, 6:51 PM   #1
Junior Member
 
Join Date: Aug 2009
Posts: 2
Default HD2000 not turning on...Help!!

Hello anyone who might be able to help me

I was casually using my HD2000 a few days ago and all of a sudden the screen went white for a few seconds and it shut off. I havnt been able to turn it back on since then. Ive tried using the AC cable through the dock and directly into the camera as well with and without the battery. Alls that happens is the red light will flash - thats it....I just received it about a week ago overseas so I don't have any warranty and I don't think service here would be cheap either. So if anyone has any insight as to what might be the problem, please please please let me know.

Thanks for your time,
Anton
PallidBoy is offline   Reply With Quote
Sponsored Links
Old Aug 25, 2009, 3:45 AM   #2
Senior Member
 
Join Date: Jan 2006
Posts: 1,092
Default

you might need to do a hard reset. I have no clue on how to do this.
Cresho is offline   Reply With Quote
Old Aug 25, 2009, 11:28 AM   #3
Junior Member
 
Join Date: Aug 2009
Posts: 2
Default

I was thinking that but I didn't know if you can do that easily. Does anyone know how to do a hard reset on an HD2000?
PallidBoy is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:05 PM.