Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sanyo

Reply
 
Thread Tools Search this Thread
Old Aug 22, 2010, 4:57 PM   #1
Junior Member
 
Join Date: Aug 2010
Posts: 3
Default Xacti VPC-HD2000EX Flashing Red Light

My Xacti is barely 5 months old and is getting a flashing red light when attempting to charge or power up. The instruction manual is useless as well as the Sanyo website. I did a google search and on this forum and found no answers. Has anyone had this problem?

Much thanks!!
hoakton is offline   Reply With Quote
Sponsored Links
Old Aug 22, 2010, 8:52 PM   #2
Member
 
Join Date: May 2009
Posts: 57
Default

The last time I had the same problem was when my HD2000 was heated up. After leaving it to cool off, it became normal again so it was some kind of over-heating protection. Not sure if yours is the same case. Cheers.
ronaldkwok is offline   Reply With Quote
Old Aug 24, 2010, 1:36 AM   #3
Junior Member
 
Join Date: Aug 2010
Posts: 3
Default

Unfortunately, my problem isn't as easy as letting it cool off. I have no idea what the problem is. Sanyo technical / customer support is non-existent. I will never buy another Sanyo product again.
hoakton is offline   Reply With Quote
Old Aug 24, 2010, 11:45 PM   #4
Senior Member
 
Join Date: Aug 2008
Posts: 224
Default

I had this problem with my HD1010 I put it down to leaving the charging dock face up on my desk for months and I think some dust or dirt got into the contacts.

I banged it a bit and it started charging. I know leave the dock upside down on my desk and have not had a problem since.
relate2 is offline   Reply With Quote
Old Aug 27, 2010, 3:33 AM   #5
Member
 
Join Date: Aug 2008
Posts: 33
Default

Does it charge when you connect the charger directly to the camera instead through the cradle?

Are you able to power up the camera, even with the red flashing light? Reseat the battery, reset to factory settings and check for dust. Most likely it's the battery.

But with 5 months old, you have warranty. Just go back to the store and demand a new one.
Rawit is offline   Reply With Quote
Old Sep 13, 2010, 10:18 PM   #6
Junior Member
 
Join Date: Aug 2010
Posts: 3
Default

Quote:
Originally Posted by Rawit View Post
Does it charge when you connect the charger directly to the camera instead through the cradle?

Are you able to power up the camera, even with the red flashing light? Reseat the battery, reset to factory settings and check for dust. Most likely it's the battery.

But with 5 months old, you have warranty. Just go back to the store and demand a new one.
No, it does charge when the charger is directly connected to the camera but there is no flashing red light. The flashing red light also comes on when I hit the power button. The batter still retains the full capacity of the battery. The thought I read somewhere that the warranty runs out at 3 months.
hoakton is offline   Reply With Quote
Old Sep 13, 2010, 11:00 PM   #7
Senior Member
 
SharpShotGal's Avatar
 
Join Date: Oct 2009
Location: Kitsap Penninsula, Washington State
Posts: 1,217
Default

3 months is usually meaning return of merchandise at what ever store thats a 90 day thing by law usually.... there is more of a Warranty than 3 months for most things.. take it back to the store and tell them that there is a battery problem....
SharpShotGal is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:40 AM.