Go Back   Steve's Digicams Forums

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: Photo 5
Forum: Fujifilm May 27, 2011, 3:46 PM
Replies: 22
Views: 3,913
Posted By Photo 5
B+H told me I need to deal with Fuji repair on...

B+H told me I need to deal with Fuji repair on this as the camera is out of there return policy and that Fuji would be ablew to repair it for me. Fuji is telling me to ship it to them at my expense...
Forum: Fujifilm May 26, 2011, 9:20 PM
Replies: 22
Views: 3,913
Posted By Photo 5
Fuji is telling me they think it has issues. ...

Fuji is telling me they think it has issues. Yeah I figured that. They want me to send it at my expense to their repair facility so they can look at it and repair it if need and get this IF IT IS...
Forum: Fujifilm May 23, 2011, 11:16 AM
Replies: 22
Views: 3,913
Posted By Photo 5
mine is a 1AA as well, updated firmware as well. ...

mine is a 1AA as well, updated firmware as well. Been around fires with no issues using this csamera or it overheating (but them again I didn't fire as many shots as fast). I got to the event...
Forum: Fujifilm May 22, 2011, 9:05 PM
Replies: 22
Views: 3,913
Posted By Photo 5
got mine through B+Hphotovideo.com I have not...

got mine through B+Hphotovideo.com I have not contacted them yet but basd on what Fuji tells me about th eproblem in general I may need too.

dave
Forum: Fujifilm May 22, 2011, 5:10 PM
Replies: 22
Views: 3,913
Posted By Photo 5
Firmware is 1.02. Sent an e-mail off to Fuji to...

Firmware is 1.02. Sent an e-mail off to Fuji to ask about this issue and if it needs repaired and how to go about doing so. I will report back based on findings.

dave
Forum: Fujifilm May 22, 2011, 2:57 PM
Replies: 22
Views: 3,913
Posted By Photo 5
I am not sure what firmwear is on the camera to...

I am not sure what firmwear is on the camera to be exact the camera is packed a way for the moment and I will check on that. But I got more than the normal red indicator I got a the word indicator...
Forum: Fujifilm May 21, 2011, 11:51 PM
Replies: 22
Views: 3,913
Posted By Photo 5
HS20 Issues

Well I thought their won't/wasn't any issues with the HS20 until this morning. Luckily I had my HS10 with me as a backup. Why I decided to pack it last night in the camera bag and leave the HS20...
Showing results 1 to 7 of 7

 
Forum Jump

All times are GMT -5. The time now is 2:04 AM.