Go Back   Steve's Digicams Forums

Showing results 1 to 5 of 5
Search took 0.01 seconds.
Search: Posts Made By: BigBad64
Forum: Canon Aug 7, 2006, 8:46 AM
Replies: 7
Views: 1,534
Posted By BigBad64
Finally got the camera back repaired today for...

Finally got the camera back repaired today for $150 AUD total.

Apparently the faulty part was the "DC-DC Converter", a circuit board.

Seems to be working OK now.

If the same thing happened...
Forum: Canon Jul 23, 2006, 6:51 AM
Replies: 7
Views: 1,534
Posted By BigBad64
I took the camera back to the repairer and he...

I took the camera back to the repairer and he said that as we had eliminated the LCD screen as the culprit then it was probably the "Illuminator" behind it, which is apparently a separate part. He is...
Forum: Canon Jun 29, 2006, 4:36 AM
Replies: 7
Views: 1,534
Posted By BigBad64
I just had a new LCD screen fitted at $150 AUD...

I just had a new LCD screen fitted at $150 AUD and guess what? The first time I turn it on, same problem. Not impressed to say the least. I'm taking it back tomorrow am. How do I know they even put...
Forum: Canon Jun 11, 2006, 4:44 AM
Replies: 7
Views: 1,534
Posted By BigBad64
I think I'll get a quote to fix it and if it's...

I think I'll get a quote to fix it and if it's too much then just buy another basic one. You would think that you'd get more than 2 years out of a camera, although maybe it would be OK if I hadn't...
Forum: Canon Jun 9, 2006, 12:59 AM
Replies: 7
Views: 1,534
Posted By BigBad64
I have a Powershot A75 that has developed an...

I have a Powershot A75 that has developed an intermittent LCD screen problem. It sometimes begins to "shimmer" and then fades to virtually black so that you can see nothing. I first noticed the...
Showing results 1 to 5 of 5

 
Forum Jump

All times are GMT -5. The time now is 1:45 AM.