Go Back   Steve's Digicams Forums >

Reply
 
LinkBack Thread Tools Search this Thread
Old Sep 18, 2006, 3:45 AM   #1
Member
 
v8griff's Avatar
 
Join Date: Oct 2004
Posts: 93
Default

Hi,

Was hoping to find a solution to my problem.

Upon trying to charge my F717 the charging light, on the rear of the camera, refuses to light up anymore. Switching the camera on shows me the battery is taking no charge. I've checked the fuse in the charger and thats ok (I've even bought another charger to try) but all to no avail.

Is there something I'm missing here?

Really hope I can sort this out, just love this camera.

TIA.
v8griff is offline   Reply With Quote
Sponsored Links
Old Sep 18, 2006, 9:38 PM   #2
Senior Member
 
Join Date: Apr 2006
Posts: 148
Default

I'd buy new battery and compact charger that charges battery off camera. Life time of battery about 3 years so do not be suprized your battery went dead
s_grins is offline   Reply With Quote
Old Sep 19, 2006, 2:58 AM   #3
Member
 
v8griff's Avatar
 
Join Date: Oct 2004
Posts: 93
Default

Thanks for the suggestion - this is the way to go I think.

External chargers seem cheap enough, I'm sure this will solve the problem.

Thanks.
v8griff is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:49 PM.