Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Sony (https://forums.steves-digicams.com/sony-34/)
-   -   I got an L1 today... (https://forums.steves-digicams.com/sony-34/i-got-l1-today-39194/)

CyberShotNut Dec 1, 2004 9:06 PM

1 Attachment(s)
I found a good deal on an L1, so I thought I'd check it out. Compared to the older U20/U30/U40, the L1 is slightly larger and has much more features. So far I've taken a few shots with it and them seem decent, although it looks to have the same very weak flash as the T1. The black plastic tripod mount adapter is ridiculous, it makes the camera much bigger, but I guess it's better than not being able to put the camera on a tripod at all.


I'll post some more comments after I check it out a bit more.

CyberShotNut Dec 2, 2004 3:40 PM

Well, i'm not very impressed by the L1. It's not much smaller than the P100,(larger with the stupid tripod bracket on)but has less features and less resolution. As I thought the flash is weak and the camera boosts up the ISO values with indoor shots which result in noisy/grainy pictures.

Outdoor pictures are very good, in my opinion they are about equal to the quality of P73 pictures. Video is great, equal to any other Sony camera with MPEG VX fine. The thing that killed it for me about this camera is the lack of any manual focus. I use 1m and 3m focus alot with my P100 taking pictures inside of clubs or at parties when there is just not enough light or time to let the camera do the focusing. For a few $ more, I think the P100 is a better choice. Up on ebay it goes.....


All times are GMT -5. The time now is 2:42 PM.