Go Back   Steve's Digicams Forums >

Reply
 
LinkBack Thread Tools Search this Thread
Old May 3, 2014, 12:36 PM   #1
Member
 
Argelius's Avatar
 
Join Date: Nov 2004
Posts: 41
Default Sony A7, dead out of the box :: any ideas?

Well, I'm bummed. I just got my A7 (from Amazon) and, evidently, it is dead.

I've inserted the battery, but camera will not turn on.

I've attached the camera (via the micro USB cable) to the charger, but the charging light doesn't illuminate.
I've tried plugging it into my computer but that doesn't work either. I've also tried a different USB cable.

I'm guessing/hoping I got a bum battery. Does anyone know if the charging light (or screen) will illuminate when the camera is plugged in but the battery is removed?

Thought I'd post here to see if there might be something (obvious, or otherwise) I'm missing.

;-(
Argelius is offline   Reply With Quote
Sponsored Links
Old May 3, 2014, 3:07 PM   #2
Senior Member
 
TCav's Avatar
 
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,733
Default

Sony Telephone Support: 1-239-245-6360
__________________
  • The lens is the thing.
  • 'Full Frame' is the new 'Medium Format'.
  • "One good test is worth a thousand expert opinions." - Tex Johnston, Boeing 707 test pilot.
TCav is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 4:35 PM.