Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Sony (https://forums.steves-digicams.com/sony-34/)
-   -   sony h-10 heating problem (https://forums.steves-digicams.com/sony-34/sony-h-10-heating-problem-145984/)

smaaz Aug 29, 2008 3:55 PM

1 Attachment(s)
hello i just bought sony h-10 after searching and reviewing alot btw tz5 sx100 and h-10 as i have two other sony aswell (N1 and t200) no doubt h-10 is a great camera but i am having a problem my cam get heated from the right side of the lcd (marked below) its very annoying when holding it in the right hand. i live in pakistan and here there is no such thing as returning the camera to get a new one onceu buy its urs so plztell me if some one else having this prob if no thn what should i doto counter this ?? one more thing why there is no date stamp option i have it in mydsc-N1 ???

smaaz Aug 31, 2008 6:48 AM

i would really like someone to reply please ....

justaman Sep 2, 2008 5:26 AM

Well I have H10, but no idea for resolving your problem...


smaaz Sep 2, 2008 1:00 PM

yesterday i took 200 shots with my cam it works fine but heats from the right side of the screen like some mobile phones when talking.....i think i should consult sony thanks anyways

Cyberf828 Sep 3, 2008 8:53 AM

I would call Sony, I know mine is not a H10 but my H5 never even got warm and I can take alot of photos in a day when its mounted to my motorcycle.

smaaz Sep 3, 2008 2:21 PM

i called the sony service center here and the said bring the camera we will open it and see what is the problem....i am sorry i am not going to do this.

justaman Sep 3, 2008 3:56 PM

Why not?

smaaz Sep 4, 2008 2:31 PM

my camera comes with a 1 year repair warranty (not replacement) and it works fine just gets warm a bit from the side so ill consult thm if there is any major issue. and i just cant see my brand new camera get literally operated :sad:


All times are GMT -5. The time now is 12:42 PM.