Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Sony Alpha dSLR / Konica Minolta dSLR, Sony SLT

Reply
 
Thread Tools Search this Thread
Old Dec 28, 2006, 3:36 PM   #1
Junior Member
 
Join Date: Dec 2006
Posts: 2
Default

After not using my Maxxum 7D for a couple of months I brought it out recently. It worked fine with one exception. The built-in flash would not work. It would not pop up in low light situations. It would not work when I manually raised it. There is no indication that the camera recognizes the flash at all. I have been through the manual and cannot see how I might have disabled it but that sure looks like what might be goin on. Otherwise I assume there is a circuitry failure. I have attached a standalone flash unit to the hot shoe and it works fine so again I question the circuitry. Has anyone encountered this problem or have any thoughts about its cause?

John


jrudd is offline   Reply With Quote
Sponsored Links
Old Dec 28, 2006, 11:34 PM   #2
Junior Member
 
Join Date: Nov 2006
Posts: 13
Default

First, the flash does not pop uo automatically, you need to use you muscle power to raise it.

Second, depending on the mode and the available light, it may decide not to fire at all.

VPiv is offline   Reply With Quote
Old Dec 31, 2006, 10:05 AM   #3
Junior Member
 
Join Date: Dec 2006
Posts: 2
Default

Thanks VPiv. I was thinking of the pop up flash on my previous 35mm SLR...a "seniors" moment! I'll continue to look at the flash settings in case I have inadvertently turned the flash off. It is just odd that the external flash I attached worked immediately without me needing to change any settings. I was expecting the same for the built-in.

John
jrudd is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:03 PM.