Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Sony Alpha dSLR / Konica Minolta dSLR, Sony SLT

Reply
 
Thread Tools Search this Thread
Old May 11, 2006, 8:59 AM   #1
Senior Member
 
Join Date: May 2006
Posts: 202
Default

The battery for my maxxum 7D is stuck inside the camera. It won't come out. Do I need to send this to minolta for repairs or what?!
maxxum7d is offline   Reply With Quote
Sponsored Links
Old May 11, 2006, 9:24 AM   #2
Senior Member
 
Join Date: May 2006
Posts: 133
Default

I am going to ask this question as if possibly this could be your first time trying to take it out because I can't imagine anything making it get stuck.

Are you pressing the battery release? If you are, is there a problem with the release and it doesn't move?
Gozinta is offline   Reply With Quote
Old May 11, 2006, 9:35 AM   #3
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Are you sure you don't have it in upside down (contacts at the top).

I did that accidently for the first time recently with my 5D (I was surprised it actually went in that way).

I decided to tap on the camera with the battery facing down and it finally fell out.

I'll make sure not to make that mistake again.

Make sure the tab holding it in place is moved out of the way, too (I assume that partis obvious).


JimC is offline   Reply With Quote
Old May 11, 2006, 10:56 AM   #4
Senior Member
 
Join Date: May 2006
Posts: 202
Default

No, I have the right way (and the camera switches on), and I am using the battery release. The battery won't budge. I bought this yesterday from adorama and I'm gonna try to see if they exchange it as a defective item.
maxxum7d is offline   Reply With Quote
Old May 11, 2006, 11:07 AM   #5
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Is it the original battery, or are you using a third party battery?

Every once in a while, you'll see an issue with some third party batteries being a tiny bit too large (making them fit too tight). I don't recall this problem being reported with any of the KM DSLR models though.

Or, perhaps you got a bum battery (something in the mold didn't work just right due to a production problem).

Good Luck with it. That Adorama deal is pretty sweet (KM 7D with a 28-75mm f/2.8 lens for under $950. since that lens normally sells for almost $400 by itself, as it's $379 at B&H right now).

I assume you got the web price with it. If not, I'd insist on it (since they may try to sell it at the higher price in the store from what I've heard, unless you question it and point out the sale price). :-)

http://www.adorama.com/IMN7DK1.html?...&item_no=1



JimC is offline   Reply With Quote
Old May 11, 2006, 11:24 AM   #6
Senior Member
 
meanstreak's Avatar
 
Join Date: Mar 2006
Posts: 1,234
Default

I bought mine at Adorama and they should exchange it with no problem if it is defective whether it is the battery or camera. I assume if the battery is the root cause of the problem, they will just try to take it out and swap batteries if they have one on hand. They swaped out my lens because it had a minor blemish on the edge of the glass. They didn't want to because they said it wouldn't affect the images, but I insisted that it was still defective and wanted an exchange. They gave in quite easily and if it is a problem with the camera, you shouldn't have a problem. I assume you purchased it from their retail store.

Did you buy it with the 28-75mm lens at 949.00? When I walked in, they tried to sell it to me separtely for much more money as Jim highlighted in a previous post.
meanstreak is offline   Reply With Quote
Old May 11, 2006, 12:07 PM   #7
Senior Member
 
Join Date: May 2006
Posts: 202
Default

Yes I bought the combo at web price, and I love it. The body seems well designed. I hate browsing through menus to change settings, something I can avoid now. I will take the camera to adorama and hopefully they will help me out.

When the camera is switched on, it makes a grinding sound before setting the lens to infinity (which makes another whirr sound). So I hear two grinding/whirring sounds after turning it on. Is this normal? Also if the flash is flipped up and I repeatedly press the shutter release fast, the flash goes "jzzzzjjj" (lights up) for second or less once in a while.

I am not sure what is normal or abnormal about this camera yet. The battery problem definitely is.
maxxum7d is offline   Reply With Quote
Old May 11, 2006, 12:16 PM   #8
Senior Member
 
cope's Avatar
 
Join Date: Jun 2003
Posts: 718
Default

maxxum7d wrote:
Quote:
Also if the flash is flipped up and I repeatedly press the shutter release fast, the flash goes "jzzzzjjj" (lights up) for second or less once in a while.

I am not sure what is normal or abnormal about this camera yet. The battery problem definitely is.
The flash is aiding the AF. This is normal.
cope is offline   Reply With Quote
Old May 11, 2006, 12:33 PM   #9
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

It does perform an initilization routine on the AS (as well as resetting focus as you noticed).

I'd let Adorama check it out for you to make sure it's OK (I can't tell how loud it is from your description, and some users perceive it as being louder than others).

As for the flash for Autofocus Assist, you can disable it in Custom Menu 2 (turn AF Illuminator Off).




JimC is offline   Reply With Quote
Old May 12, 2006, 8:59 AM   #10
Senior Member
 
Join Date: May 2006
Posts: 202
Default

I hope this counts as a positive review for adorama, they gave me a replacement today without any problems. I look forward to enjoying my camera before Sony comes out with something better. Thanks for your help everyone!
maxxum7d is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:58 AM.