Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Sony Alpha dSLR / Konica Minolta dSLR, Sony SLT

Reply
 
Thread Tools Search this Thread
Old Jun 1, 2006, 1:42 PM   #1
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

Funny no one mention this, but USA Today mentioned this 10Mp dSLR replacing the D7 in yesteday edition

-> It's due to released in July for about $1000 and will be called the A100
NHL is offline   Reply With Quote
Sponsored Links
Old Jun 1, 2006, 2:31 PM   #2
Senior Member
 
cope's Avatar
 
Join Date: Jun 2003
Posts: 718
Default

I saw this at dpreview's KM forum. There hasn't been the hysterical speculation here that has been going on at that forum, that's probably why it went unmentioned.
cope is offline   Reply With Quote
Old Jun 30, 2006, 1:55 AM   #3
Junior Member
 
Join Date: Jul 2005
Posts: 3
Default

Do you know if Sony A100 uses regular lens and filter or only custom Zeiss?

judee:idea:
judee is offline   Reply With Quote
Old Jun 30, 2006, 8:22 AM   #4
Senior Member
 
cope's Avatar
 
Join Date: Jun 2003
Posts: 718
Default

The Alpha will use Minolta's A mount, the same as on all Minolta AF cameras since 1985. As with the 5D and 7D, all Minolta lenses and most aftermarket lenses will work.
cope is offline   Reply With Quote
Old Jun 30, 2006, 8:23 AM   #5
Senior Member
 
Join Date: Mar 2004
Posts: 120
Default

It uses the Minolta AF mount so all old Minolta/KM lenses fit. Most of the Sony lenses for it are rebadged Minolta lenses.
Technophile is offline   Reply With Quote
Old Jun 30, 2006, 12:00 PM   #6
Junior Member
 
Join Date: Jul 2005
Posts: 3
Default

So can you use third party lenses and filters with the Konica mount? from judee
judee is offline   Reply With Quote
Old Jun 30, 2006, 12:03 PM   #7
Senior Member
 
Join Date: Sep 2005
Posts: 159
Default

Anything that fits the old Maxxum/Dynax/Alpha mount will fit the new A100. I supposed it may has the same limitation as the Maxxum in that some sigma and such doesn't work with AS and AF...
RacingManiac is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:42 PM.