Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old May 2, 2007, 2:43 AM   #11
Junior Member
 
Join Date: May 2007
Posts: 27
Default

camperbc wrote:
Quote:
Hi again Muddy,
I just got an email back from Sony Canada, and they said I should call Sonystyle.ca where I bought it from, and that they will likely send me a new adapter. I will call them tomorrow and report back with my findings.
Hello there, and tnx for the quick reply.
I got my camera from the local dealer here in Croatia. I seriously doubt that I can bring it in and have it replaced. I will try nevertheless and see what happens, but I won't hold my breath. :roll:
So I ask again, can this thing be purchased separately in the States (or Canada)?


Quote:
In the meantime, you can still use the adapter and hood the way it is; you just have to loosen the threads off a bit to line things up properly.
Yeah, but this is sooooo not the way I wanted to use my brand new kicka** camera, with a lens hood wobbling and me worrying whether it's going to fall off... :shock:
muddyfox is offline   Reply With Quote
Old May 2, 2007, 3:53 AM   #12
Member
 
Join Date: Apr 2007
Posts: 54
Default

I am a little reluctant too, to start banging away at trying to loosen it, but if the Sony people tell me tomorrow that I am getting a new one sent to me, I will get more physical to free it. If it frees up, I would be happy to mail it to you, if you are unable to get your supplier to help you out.
Otherwise, surely your supplier will honour the warranty? How can they not?
I will let you know as soon as I hear that a new one is coming, and will then work at fixing mine.
camperbc is offline   Reply With Quote
Old May 2, 2007, 4:17 AM   #13
Junior Member
 
Join Date: May 2007
Posts: 27
Default

camperbc wrote:
Quote:
Otherwise, surely your supplier will honour the warranty? How can they not?
Don't get me started... :roll:
Things have a way of not working the way they should over here... sometimes it is necessary to :P and :P to get things done, and frankly I don't have a stomach for it.
If the camera was broken then they just might replace it. Ordinarily they just chalk it up to something not covered in warranty and send you on your merry way...
And given it's just a piece of plastic that I'm complaining about, I'll probably just get mocked and pretty much ignored. "Yeah, we'll order a replacement and contact you when it comes in." Then I won't hear from them for about 6 months during which time any phone call will be put on indefinately long hold...
Sheesh...
Nevertheless, I'll try that route and see what happens...


camperbc wrote:
Quote:
I will let you know as soon as I hear that a new one is coming, and will then work at fixing mine.
I hope you get a new one and beat this one into submission, so that I can fix mine as well. :-x

muddyfox is offline   Reply With Quote
Old May 2, 2007, 7:03 PM   #14
Senior Member
 
nickphoto123's Avatar
 
Join Date: Aug 2004
Posts: 1,356
Default

I think I discovered cause of the problem.

While taking off my adapter today, I found that if you take the lens hood off, the outer position ring moves and clicks freely.BUT... When you install the lens hood, the lens hood locks the outer position ring, it no longer is able to turn,at least on my camera.

Hope this helps. Let us know if this works for you.

Nicholas
nickphoto123 is offline   Reply With Quote
Old May 2, 2007, 8:04 PM   #15
Member
 
Join Date: Apr 2007
Posts: 54
Default

Hi Nicholas,
The problem with mine is that the adjusting ring is fused tightly with the adapter, whether the hood is attached to it or not. I think this is also the case for Muddy.
I called Sony today, and they are sending me a replacement adapter. I hope it works better than this one!
camperbc is offline   Reply With Quote
Old May 2, 2007, 11:31 PM   #16
Senior Member
 
nickphoto123's Avatar
 
Join Date: Aug 2004
Posts: 1,356
Default

Great. Glad they gave you the right response, a new one.
nickphoto123 is offline   Reply With Quote
Old May 3, 2007, 1:57 AM   #17
Junior Member
 
Join Date: May 2007
Posts: 27
Default

camperbc wrote:
Quote:
Hi Nicholas,
The problem with mine is that the adjusting ring is fused tightly with the adapter, whether the hood is attached to it or not. I think this is also the case for Muddy.
I called Sony today, and they are sending me a replacement adapter. I hope it works better than this one!

Ditto... one can hardly tell that it's actually made of two pieces...
Camper, please take a hammer to yours when you get a replacement, maybe you can get it turning... :G


muddyfox is offline   Reply With Quote
Old May 3, 2007, 3:02 AM   #18
Member
 
Join Date: Apr 2007
Posts: 54
Default

Hi Muddy,
I just got mine freed up!!!
I dug my nails (both hands) into the groove between the front of the main adapter piece and the adjusting ring, and tried pulling the ring back toward me. At first nothing happened, then I helped it along by gently prying a butter knife into the crack and twisting the knife a bit, then pulling again. Finally it popped apart.
I snapped it back into place again, and now it works fine. Go figure!
Anyway, my new one is on the way, so if you cannot get yours loose, and can't get your store to help you out, I will be happy to send you mine, once the new one arrives.
Let me know how you make out with it.
camperbc is offline   Reply With Quote
Old May 3, 2007, 3:16 AM   #19
Junior Member
 
Join Date: May 2007
Posts: 27
Default

Camper, that's really good news!

I was going to go to my dealer after work, but now that you've fixed your adapter, I lost my patience. I'm having my wife bring it over here in about half an hour and I'll give it a go ASAP.

Will check back in about half an hour with the results...



muddyfox is offline   Reply With Quote
Old May 3, 2007, 4:49 AM   #20
Junior Member
 
Join Date: May 2007
Posts: 27
Default

Camper, I owe you a big one!

It works!

Done exactly what you said, took a knife to it, snapped the ring free and put it back... you've just saved me A LOT of bureaucratic hassle and very likely a big dissapointment few months down the road...
Drinks are on me if you ever happen to be this side of the big pond...
muddyfox is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:12 PM.