Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old Aug 26, 2007, 3:23 PM   #1
Junior Member
 
Join Date: Aug 2007
Posts: 4
Default

Hi. I did a search on this and didn't find an answer, so I decided to post up.



I bought a DSC-P200 about a year and a half ago, shortly after that it went in for repair for the flash not working properly. Now 3 months out of warranty, it started freezing up. But I'd turn the power on and off, or take the battery out and it would be fine again.

Yesterday it did the same, I took out the battery and hit reset. But now the lens is stuck out, but the camera will power on. It'll say accessing, then it'll tell me to turn the power on and off again. The lens seems to be trying to go back in, but it won't. The shutter still works from what I can tell. The preview mode and screen work as well.

Any ideas? I'm trying to find a local store that deals with Sonys, but I figured I look it up a little.

Thanks in advance
FoxShox is offline   Reply With Quote
Sponsored Links
Old Aug 26, 2007, 3:49 PM   #2
Member
 
Join Date: May 2007
Posts: 82
Default

When all else fails........smack it!!!!!!!!!!!! You might be surprised.
CB401 is offline   Reply With Quote
Old Aug 26, 2007, 4:00 PM   #3
Junior Member
 
Join Date: Aug 2007
Posts: 4
Default

CB401 wrote:
Quote:
When all else fails........smack it!!!!!!!!!!!! You might be surprised.
No kidding CB, I just did some googling and came across this thread bellow. I was a little hesitant to smack a camera with such little use, but what do you know....a few good smacks on my lap and off it went, wow. Shame on Sony none the less.

http://www.pechorin.com/m/2006/08/24...em-270736.html
FoxShox is offline   Reply With Quote
Old Aug 26, 2007, 6:14 PM   #4
Member
 
Join Date: May 2007
Posts: 82
Default

Glad it helped. It probably sounded like I was being a smart aleck, but I had also come threads where it had fixed the lens issues before. Good luck and good pictures.
CB401 is offline   Reply With Quote
Old Aug 26, 2007, 8:09 PM   #5
Junior Member
 
Join Date: Aug 2007
Posts: 4
Default

We'll see how long it'll work. Its such a shame because otherwise its a great little camera. Now I'm turned off Sonys.
FoxShox is offline   Reply With Quote
Old Aug 27, 2007, 4:29 PM   #6
Senior Member
 
Cyberf828's Avatar
 
Join Date: Sep 2006
Posts: 659
Default

FoxShox wrote:
Quote:
We'll see how long it'll work. Its such a shame because otherwise its a great little camera. Now I'm turned off Sonys.
Don't be turned off every brand has it quirks.
Cyberf828 is offline   Reply With Quote
Old Aug 28, 2007, 11:45 AM   #7
Junior Member
 
Join Date: Aug 2007
Posts: 4
Default

All brands and makes of everything do have their quirks. But seeing how common this problem is with so many Sony models, and how they don't offer any help, or good will fixes, they're not scoring very high or holding up to the Sony reputation. I'm very likely going the Canon or Nikon route next time.
FoxShox is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:34 AM.