Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Sony (https://forums.steves-digicams.com/sony-34/)
-   -   Sony DSC-H5 drains Batteries (https://forums.steves-digicams.com/sony/201486-sony-dsc-h5-drains-batteries.html)

hsgram Sep 8, 2012 9:18 PM

Sony DSC-H5 drains Batteries
 
I have a Sony DSC-H5 and for the first few years I had it, it worked well. But, now it drains every battery I put in it and I can only take a small number of photos before the battery is gone. Even more frustrating, when using the flash, it takes forever for the blinking flash light to go off so I can take another photo.

I have tried all different types of batteries and a few chargers, but nothing helps. Can anyone help me with this because I can't get any decent photos of my kids. All the shots pass me by!

Thanks so much!

fewpics Sep 11, 2012 6:03 PM

hsgram,,

These are classic symptoms of a dying battery... Does your H5 have its own particular Sony type battery or does it take the likes of AA's etc.??

If its a Sony battery, the cure may be to get another. If they are AA's and rechargeables, the same thing may well help you - new batteries. If this is an ongoing problem with replaceable, non rechargeable batteries, AA's etc, and its getting worse,, then you have a problem...

From your limited description above, it's hard to judge...

hsgram Sep 11, 2012 10:34 PM

Quote:

Originally Posted by fewpics (Post 1318099)
hsgram,,

If this is an ongoing problem with replaceable, non rechargeable batteries, AA's etc, and its getting worse,, then you have a problem...

From your limited description above, it's hard to judge...

It IS an ongoing problem. I can get a few more pics with AA batteries than with rechargeable ones, but they don't last long either. I received a new battery charger and a bunch of new rechargeable batteries, but they seem to do the same thing. I'm not sure how long a set of AA alkaline batteries should last so I'm not sure if it the time is abnormal. I just know I'd be in the poor house if that's all I used!

What do you think it might be if it is an ongoing issue. Could the battery chargers be ruining my batteries? As I stated in my first post, for the first few years after I got the camera, it worked just fine, but it is so frustrating now that I don't know what to do.

Thanks for your help!

lisalonewolf Nov 16, 2012 11:52 PM

This happened with my camera as well. I went with high grade batteries charged them well. This helped. It is not at good as my other cams which use lithium batteries. For some reason this and the kodak 990 kills batteries fast.

Good luck

Tullio Nov 19, 2012 4:47 PM

I have an old H1 and never experienced this proble. I use the Eneloop battery and they last 250+ shots. Now, I used to use the EVF all the time, which would help save battery juice. How many pictures can you get with one full charged set of batteries?

Grovegal Dec 4, 2012 10:22 AM

@hsgram I am having the same problem and it began last year. I phoned Sony who suggested that I send it back for repairs - fee is $192 and you can ship it here:

Sony Repair Center
10227 Crossroads Loop, Suite C
Laredo, TX 78045

He suggested first that LED light be set to normal; click on Initializing then again on OK to restore it to factory settings. Make sure display resolution is standard.

If that doesn't help with battery life then he suggests sending it back.

I am surprised this has been a persistent problem with this camera as you can see with a Google search yet Sony does not acknowledge it.

Hope that helps.


All times are GMT -5. The time now is 10:20 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 RC 2