Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old Feb 17, 2005, 6:46 AM   #1
Member
 
Join Date: Jan 2005
Posts: 73
Default

Uhm, I hope I did not damage the camera.

I had my shutter closure set very long the other day, and so today at work I took my camera, started it and it got to the manual (m), but it's a well lit room, so the LCD of course, turned white, I immediately lowered the shutter length, but now the thing is flickering. I've damaged the sensors? I hope I haven't.
Manolito_Mystiq is offline   Reply With Quote
Sponsored Links
Old Feb 17, 2005, 9:49 AM   #2
Member
 
Join Date: Jan 2005
Posts: 73
Default

Hmm, there's still flickering, hardly as much as it were in the morning (my first post). Maybe it's normal, though, I don't know. I was just shocked that the whole LCD went flickering, when I shorten the shutter speed. I reseted the camera, but then it didn't help, but now that it's some hours later, it may have restored it a bit. I guess it's something with the sensor which senses the brightness that went malfunctioning.

I hope there isn't any permanent damage. I'll post a video I made when I had a lot of flickering, so you can see for yourself.
Manolito_Mystiq is offline   Reply With Quote
Old Feb 17, 2005, 10:50 AM   #3
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

The LCD flickering in low light is normal.

If you try it outside in better light, you'll see what I mean.

In low light (and a well lit interior is low light to a camera), the CCD photostites don't have enough light hitting them to generate a good enough signal to drive the display. So, it must wait longer for the individual "wells" to fill on the photosites before reading the signal from them between frames -- hence they use a slower refresh rate.

Many cameras use two techniques to let you see the LCD betterin low light. They "gain up" the CCD (amplify it's signal -- just like using a higher ISO speed), which is why it looks so grainy in low light, and they also slow the refresh rate down (which is probably the flicker you're noticing).

If they did not use these two techniques, your display would be dark as light got lower (imagine trying to take a photo in low light indoors at 1/30 second and ISO100 with no flash -- you'd get a dark photo). This is what you'd see on an LCD if you tried to refresh the display at 30 frames per second and did not gain up the signal.

As a result, some models that don't gain up the signal from the CCD and slow the refresh rate down, become totally unusable in low light (their displays become too dark to see).

Try it in better light outdoors and see if the problem goes away.

JimC is offline   Reply With Quote
Old Feb 17, 2005, 11:13 AM   #4
Member
 
Join Date: Jan 2005
Posts: 73
Default

The thing is, it wasn't in low light. It was in well a well lit room.

I never had this flickering before, grain yes, but not flickering.

Now the green, the grey, the red, all looks grainy.

It's like the sensor had gone crazy, because you see 'bright, not bright, bright not bright' flickering. I show you a video.


EDIT: ah sorry, yes you're right about well lit rooms also being low light to the camera. But the LCD turned really white when lowering the shutter speed (which was probably a stupid thng to do). I really fear I've damaged sensors. Maybe I haven't and am just seeing things that aren't there.


EDIT2: The manual didn't warn about this, though. It did warn not facing it to direct sunlight, though.
Manolito_Mystiq is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:45 PM.