Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old Nov 11, 2005, 10:04 AM   #1
Junior Member
 
Join Date: Aug 2005
Posts: 11
Default

Just got a MAVICA CD400. It powers on well, problem is that there is always an error saying COVER OPEN. I had a CD200 before & this is very similar. It should tell me cover open when the disk door is open but even after closing it i keep getting the COVER open on LCD. I can not see any broken piece, the opening part moves up & down. HELP. I can't use the camera.
rinabella1 is offline   Reply With Quote
Sponsored Links
Old Nov 11, 2005, 2:20 PM   #2
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

When the cover is closed the plastic tab on the bodypushes the metal tab on the coverin and closes two microswitches. (see pics below) Make sure the plastic tab is not broken and the metal tab is not missing. If everything looks good, you may have a bad switch inside the back cover.
Attached Images
 
CyberShotNut is offline   Reply With Quote
Old Nov 11, 2005, 2:27 PM   #3
Junior Member
 
Join Date: Aug 2005
Posts: 11
Default

everything looks good, just like your picture. so if it is a bad switch inside what is the fix? i have contacted seller, if i can't fix it i may request refund but i REALLY don't want to do that.
rinabella1 is offline   Reply With Quote
Old Nov 11, 2005, 2:41 PM   #4
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

The next thing you would have to do would be to take the cover off and test both switches with an ohm meter. Also, make sure the plastic switch tops are not broken.
Attached Images
 
CyberShotNut is offline   Reply With Quote
Old Nov 11, 2005, 4:24 PM   #5
Junior Member
 
Join Date: Aug 2005
Posts: 11
Default

thanks, i will try that and give you an update!
rinabella1 is offline   Reply With Quote
Old Nov 13, 2005, 10:18 PM   #6
Junior Member
 
Join Date: Aug 2005
Posts: 11
Default

any idea how much it will cost to fix this?
rinabella1 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:14 AM.