Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old Nov 22, 2005, 6:51 PM   #1
Junior Member
 
Join Date: Nov 2005
Posts: 23
Default

I have a DSC-S30that worked fine,except itwas having problems with the zoom. I replaced the power/zoom control switch assembly with a new one. Now when I power on camera, for "infolithium battery" only, pops up on screen,then camera shuts off,a few seconds later. I've replaced many of these switches before,and never had this problem pop up. What caused this and how do I fix it? thanks. Enclosed is a pic of the screen before it turns off. The on/off switchworks and zoom works.

Fixed my own problem, cable to battery compartment wasn't seated properly in memory/battery board.
Attached Images
 
2ndhandsony is offline   Reply With Quote
Sponsored Links
Old Nov 24, 2005, 1:57 AM   #2
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

There is an IC on the main board that communicates with the battery to determine remaining minutes, when this IC is bad or a connection between the battery and this IC is bad you will get that error.
CyberShotNut is offline   Reply With Quote
Old Nov 24, 2005, 2:43 PM   #3
Junior Member
 
Join Date: Nov 2005
Posts: 23
Default

Thanks for the info. It's nice to have someone that knows what he's talking about. I did what you said and I'm back in business.
2ndhandsony is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:39 PM.