Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old Jan 28, 2006, 5:01 AM   #1
Junior Member
 
Join Date: Jan 2006
Posts: 2
Default

I have a Sony DSC-P92, but i can't take fotos with it. The lins opends okey, every thing looks good but nothing happends when i push the button. I tried to change batteries and memorystick and nothing helps solving the problem.

And my display is broken so i cant see if it ses something.
FishFace is offline   Reply With Quote
Sponsored Links
Old Jan 28, 2006, 2:13 PM   #2
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

The camera is prpbably in clock setup mode. Press the center button about 10 times and it should work fine after that.
Attached Images
 
CyberShotNut is offline   Reply With Quote
Old Jan 28, 2006, 2:42 PM   #3
Junior Member
 
Join Date: Jan 2006
Posts: 2
Default

Thaksworksfinenow
FishFace is offline   Reply With Quote
Old Feb 4, 2006, 11:35 PM   #4
Senior Member
 
Join Date: Jan 2006
Posts: 142
Default

You can get a new LCD for about $40. i have one now (DSC V1) that has a broken display and i use the "tv video out" and hook it to my tv to set it up then i go and take my shots and then upload. You dont HAVE to have a display but it really helps at times. My camera said there is a rechargable internal battery that stores the time and stuff and if you dont use it for a while the battery goes dead till you use it again. Kinda weird it does that. First time ive heard of a rechargable button battery.
BowerR64 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:49 AM.