Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old Jun 13, 2006, 10:48 PM   #1
Junior Member
 
Join Date: Jun 2006
Posts: 6
Default

This seems to be the problem as I just came back from Alaska with 700 pictures. I notice a small black spot on most of them.

Sony charges 181.00 to look at the camera, hell I could get another one at that price.

Does anyone have a fix for this problem and/or can the camera be taken apart and repaired.

Any help is appreciated.

Rixter
rixter67 is offline   Reply With Quote
Sponsored Links
Old Jun 14, 2006, 2:20 AM   #2
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

Get yourself a strong vacuum cleaner with a plastic nozzle that will go over the lens assembly when it is extended, turn the vac on and lightly tap the side of the camera while zooming in and out. This worked well on my P100 that had dirt in the lens.
CyberShotNut is offline   Reply With Quote
Old Jun 14, 2006, 5:30 AM   #3
Junior Member
 
Join Date: May 2006
Posts: 4
Default

Can you recommend a good vacuum cleaner? What cleaner is useful for you?
Techno_Zafira is offline   Reply With Quote
Old Jun 14, 2006, 1:09 PM   #4
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

I just used a shop vac with a plastic nozzle.
CyberShotNut is offline   Reply With Quote
Old Jun 14, 2006, 2:37 PM   #5
Junior Member
 
Join Date: Jun 2006
Posts: 6
Default

Thanks Cyber. I tried with my vaccum, but didn't tap and zoom in and out. I will try that when I get home.
rixter67 is offline   Reply With Quote
Old Jun 30, 2006, 9:17 AM   #6
Junior Member
 
Join Date: Jun 2006
Posts: 2
Default

Thank you so much for the vacuum cleaner suggestion! I had tried blasting air into my P150 and even tried removing the screws and opening the shell (this still doesn't let you get at the sensor or lens, and I didn't have the nerve to take it apart further).

The vacuum cleaner succeeded in removing the spot of dust which had been plaguing my pictures for 2 weeks. I had even started shopping for a new camera but am now much happier keeping my P150!
-Ralph
rgonzale is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:33 PM.