Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Reply
 
Thread Tools Search this Thread
Old Jun 16, 2006, 8:19 PM   #1
Junior Member
 
Starstreams's Avatar
 
Join Date: Sep 2005
Posts: 20
Default

I am totally confused here; my camera was fine two weeks ago.
I turned it on outside and All the sudden the image preview is all distorted. I can not make anything out.


The colors look like paint dripping into each other.
What could be wrong? It was in my closet so know one touched it and I keep my room locked. Like I said the camera was fine two weeks ago when I used it last.

Starstreams is offline   Reply With Quote
Sponsored Links
Old Jun 16, 2006, 8:49 PM   #2
Senior Member
 
Trique Daddi's Avatar
 
Join Date: Apr 2004
Posts: 282
Default

See the Notice thread on top of the previous page. The processor just went out but Sony will warranty it. I just received mine back after less than 2 weeks. Click on the llink provided and they will send you a shipping label.

Good luck!

Trique Daddi
Trique Daddi is offline   Reply With Quote
Old Jun 16, 2006, 9:02 PM   #3
Junior Member
 
Starstreams's Avatar
 
Join Date: Sep 2005
Posts: 20
Default

Thanks Trique Daddi
I acctualy just contacted them. they are sending me a UPS lable to ship it to them.

By the way, did you notice any difference in image quality when you got yours back?


Starstreams is offline   Reply With Quote
Old Jun 16, 2006, 10:07 PM   #4
Senior Member
 
Trique Daddi's Avatar
 
Join Date: Apr 2004
Posts: 282
Default

I have only taken a few test shots. I have since bought a Canon 20D so I will use it as a back up now. I got veryt good performance out of the Sony though! Good luck!

Trique Daddi
Trique Daddi is offline   Reply With Quote
Old Jul 4, 2006, 2:52 AM   #5
Junior Member
 
Join Date: Jul 2006
Posts: 1
Default

I can't see the link you posted. Can you post the address? Thanks
DarkSol is offline   Reply With Quote
Old Jul 8, 2006, 3:31 AM   #6
Junior Member
 
Starstreams's Avatar
 
Join Date: Sep 2005
Posts: 20
Default

What do you mean link? there is no link I just used gree text.

hmm, or thats how it looks in my screen



by the way, I got my camara back fixed. I hope this lasts now
Starstreams is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:08 PM.