Go Back   Steve's Digicams Forums > Welcome Center > Steve's Latest Reviews

Reply
 
Thread Tools Search this Thread
Old Dec 9, 2013, 4:03 PM   #1
Senior Member
 
billy's Avatar
 
Join Date: May 2004
Location: Ohio USA
Posts: 1,733
Default Nikon Coolpix AW110

See Steve's hands on review here:

Nikon Coolpix AW110

billy is offline   Reply With Quote
Sponsored Links
Old Dec 9, 2013, 5:32 PM   #2
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,741
Default

Given it's "genre", I think it competitive on the spec sheet- and indeed waterproof to 18m is quite something- though given the lack of light at such depths- might be of little value...!
SIMON40 is offline   Reply With Quote
Old Dec 18, 2013, 4:00 PM   #3
Junior Member
 
Join Date: Mar 2007
Posts: 7
Default Nikon AW110 Comments

I enjoyed your review, and agree with most all of the points. I do want to comment however, because I own one of these cameras, and based on my experience with it, I will not buy another Nikon product.

My AW110 had issues from day one. Initially nothing to get service over, but display glitches during focusing and zooming made we wonder about the quality.

We then took the camera on a cruise last september, and it was getting usage on the order of taking 50-100 photos a day. With GPS on. The camera developed a hard issue. It began to lock up. When it goes into lock up, you have to pull the battery to reset the camera. I am not sure if the locks up were heat or usage related, or something else.

I sent the camera into Nikon repair. The camera came back with "Cleaned, and adjusted the white balance" .. Well I have enough experience in electronics service (I used to work at an electronics repair facility) to know this really meant the tech could not find anything wrong. This could also mean the tech did not spend enough time stressing the camera.

So, the very next time I take the camera out to use it, I took 6 pictures over 5 minutes, and on the 7th picture, the camera freezes up again. This time I noticed that the freeze up occurred on a zoom operation.

I sent it back in for repair, and explained in great detail how to reproduce the problem. One week later, back the camera comes "Could not find anything wrong" .... It is clear to me, based on the 1/2 day in was in the facility, that no real testing was done on the camera.

So now I am afraid to use this camera .. and I won't be buying any more Nikon products .. since they have this kind of product quality, and equally poor product service...

This is my experience with this camera .. Your Mileage May Vary ..
dblml320 is offline   Reply With Quote
Old Dec 26, 2013, 7:58 AM   #4
Senior Member
 
Join Date: Jun 2013
Location: Comox, Vancouver Island, BC Canada.
Posts: 102
Default

Quote:
Originally Posted by dblml320 View Post
So now I am afraid to use this camera .. and I won't be buying any more Nikon products .. since they have this kind of product quality, and equally poor product service...

This is my experience with this camera .. Your Mileage May Vary ..
It is a Point & Click Nikon... Nothing more.. IF you want an underwater camera, (EBAY has a few different ones buy or have built an underwater housing for a DSLR, or a good CMOS camera. I have a Nikon L24, that I put into a heavy duty ziplock bag, draw out all the air, and use it in shallow water, and it works just fine..

The thing people dont realize with Point & Clicks, is they're not ment to be heavily used. They're a pocket camera, and ment for the weekend warrior, who is going to take a few pictures, and not 50 to 100 a day.

As for Nikon's tech repair, you have to think, they have probably a few hundred cameras waiting to be worked on, and they dont stress cameras too much, incase they really do break them, and then they have to be replaced.. I too have worked in Service Depots, Now, if you are still under warrenty, and you can document it locking up (IE: take a picture of it locked up with another camera) and send that in with your camera, they might look into a little more, or Nikon might replace it..
__________________
Weapons of choice:

FujiHS20 (used all the time)
Nikon Coolpix L24 (used all the time)
Nikon D60 DSLR (rarely used anymore)
Olympus 8000 (never used anymore, as I lost my data cable).
Pantharen is offline   Reply With Quote
Old Mar 2, 2014, 7:41 PM   #5
Junior Member
 
Join Date: Mar 2014
Posts: 1
Default AW110 program freeze. CPU lock up.

My AW110 had issues from day one. Initially nothing to get service over, but display glitches during focusing and zooming made we wonder about the quality.

We then took the camera on a cruise last September, and it was getting usage on the order of taking 50-100 photos a day. With GPS on. The camera developed a hard issue. It began to lock up. When it goes into lock up, you have to pull the battery to reset the camera. I am not sure if the locks up were heat or usage related, or something else.

I sent the camera into Nikon repair. The camera came back with "Cleaned, and adjusted the white balance" .. Well I have enough experience in electronics service (I used to work at an electronics repair facility) to know this really meant the tech could not find anything wrong. This could also mean the tech did not spend enough time stressing the camera.

So, the very next time I take the camera out to use it, I took 6 pictures over 5 minutes, and on the 7th picture, the camera freezes up again. This time I noticed that the freeze up occurred on a zoom operation.

I sent it back in for repair, and explained in great detail how to reproduce the problem. One week later, back the camera comes "Could not find anything wrong" .... It is clear to me, based on the 1/2 day in was in the facility, that no real testing was done on the camera.

So now I am afraid to use this camera .. and I won't be buying any more Nikon products .. since they have this kind of product quality, and equally poor product service...



Just want to say thanks for this post. First day out for a walk along the promenade - my new AW110 froze up. I'll be taking it back to Target' immediately. Thank God I saw the problem now and not after hiking 10 miles up the Sierras.
MakeANoteOfThat is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:15 PM.