Steve's Digicams Forums

Steve's Digicams Forums (
-   Studio Lighting, Flash & Other (
-   -   [Recovered Thread: 101262] (

courage Aug 23, 2006 8:10 AM

I'm trying to figure out a way to trigger a studio flash from my Sony Alpha. I've tried the third party Dynax hot shoe / pc socket adapter ("Hot Shoe Adapter III") but it doesn't seem to work with the Alpha. I've also thought about using the built-in flash as a trigger but there does not seem to be any way to disable the pre-flash.

JimC Aug 23, 2006 9:11 AM

Which adapter have you got? Is it this one? That's the one you want. It's got Hotshoe Adapter III on the front. But, it's the version 1 adapter.

Nick is sold out. But, another vendor is Hong Kong still has them (just search for FS-1100 on Ebay and you'll find them for $14.95).

Nick (a.k.a., Digital_Initiatives) made another one (called Version III) that requires that you plug it into a PC Sync Port on the camera:

But, the Sony doesn't have a PC Sync Port and it won't work with your Sony.

The first adapter should work if that's the one you have. But, don't try to plug any strobes into it's PC Sync port or hotshoe with trigger voltages much higher than 6 volts. Otherwise, you'll risk frying your camera.

I've seen other people report trying to plug strobes into it with high trigger voltages report that it didn't fire them either. They are lucky their camera wasn't fried, since this adapter does *not* have any voltage protection built in.

Perhaps something in the camera didn't allow the strobes to latch as a protective mechanism or something (speculation). Hopefully, you didn't fry the hotshoe electronics.

Modern hotshoes are designed for strobes with lower trigger voltages, and the FS-1100 and equivalent adapters do not have any voltage isolation.

If you need to attach an older strobe with higher trigger voltages directly to the camera via a PC Sync Port, then a Minolta PCT-100 will allow you to do that. It's got voltage isolation built in for strobes with trigger voltages up to 400 volts (which is one reason it costs more than the FS-1100).

But, they're getting hard to find, and they're a bit pricey.

So, your best bet is the 3rd party FS-1100 equivalent like the one in the first link I posted, using a strobe via the hotshoe or it's PC Sync Port to trigger your slaves. Just make *sure* they have a reasonably low trigger voltages (around 6 volts), or use a radio trigger instead.

Here is a recent thread discussing this same issue, where I mentioned some cheap strobes I'm using with my Maxxum 5D via this adapter, along with a link to trigger voltages for popular strobes. You'll also see some other solutions discussed:

courage Aug 23, 2006 9:31 AM

The adapter I have looks exactly like the one in the first picture (sent to me by a friend in HongKong). It connects to the hot shoe on the Alpha but also has a PC socket. I'm not attaching it directly to the flash I'm trying to get it to fire a remote IR trigger. I've tried connecting the trigger to the hot shoe and alternatively using the PC socket but no luck. I even tried a second adapter (they had one in my local photo store) but got the same results.

JimC Aug 23, 2006 9:39 AM

That sounds like a compatiblity issue with the trigger then (or a bad trigger).

This adapter works fine with strobes I've tried with it on my KM 5D (and i make sure their trigger voltages are relatively low). The hotshoe on the new Sony should be identical.

The adapter is only a mechanical adapter (no built in electronics), just like the FS-1100 (no electronics, as it's only wiring the correct pins to trigger an ISO standard foot. I've discussed this with Nick (he makes them) before. I've also seen users report using Pocket Wizards via an FS-1100 (and if it works, so should your adapter).

He has noted problems triggering some strobes before. But, most should work just fine. So, something about your IR trigger isn't working right with an ISO Standard shoe -- possibly some kind of compatiblity issue with the electronics in the camera, or perhaps the polarity is reversed with your trigger (happens from time to time with some manufacturers). Most should work just fine though.

I'd see if you can trigger an ISO standard strobe with it if you have a camera store nearby or have a strobe with relatively low trigger voltages that you could try with it. That would rule out any problem with the camera's circuitry for the hotshoe and the adapter (which is only mechanical with no electronics). I guess it's possible you got an adapter that had a cold solder joint or something. But, if you tried another one, that shouldn't be the case.

Are you sure your trigger actually works with other cameras?

courage Aug 23, 2006 9:59 AM

Thanks for the the response. The trigger (Kepcor IR Flash Trigger) works fine on my other camera (Sony DSC-F828) and I tried getting the adapter to work with a very basic strobe in the camera shop (no idea about the trigger voltage) but no luck.

JimC Aug 23, 2006 10:07 AM

That doesn't sound good (if it wouldn't trigger a basic strobe in the camera shop).

Just for the heck of it, make sure the flash mode is set to pre-flash TTL in the camera menus, just in case something in the electronics won't let it fire properly if it's set to ADI. That's the way I usually leave my 5D set (pre-flash TTL). But, I haven't tried triggering a strobe via the adapter with it set to ADI.

courage Aug 23, 2006 10:13 AM

Thanks, I'll give that a try when I get home.

JimC Aug 23, 2006 4:34 PM

I did some digging and found someone using the adapter you and I have with a Sony DSLR-A100 with no problems. I didn't think that Sony changed anything with the hotshoe (but, I wanted to check around just in case).

The hotshoe should also work regardless of flash mode (at least my 5D does with this adapter using my Sunpaks)..

I'd try a different flash mode just to see. But, it looks like something else is probably going wrong (something that the camera's electronics doesn't like, bad adapter, not getting a good connection, defective hotshoe in camera, etc.).

courage Aug 24, 2006 2:39 AM

Thanks for the info. It might be a bad adapter but I tried a second adapter in the camera shop and that also failed so perhaps there is something wrong with the camera electronics. I have an old Dynax 3000i which seem to have the same hot shoe, so as soon as I can find a battery for it I'll give the adapter another go. If the adapter works I'll have to get hold of a Sony/Minolta flash to test the camera with. Anyway thanks for all your efforts.

JimC Aug 26, 2006 7:41 AM

Unless you are not makng a good connection (make sure the locking lever or knob on your trigger has it locked down tightly to the adapter), I don't know what would be wrong other than the camera not liking something about the trigger (or the camera actually having a defective shoe).

All times are GMT -5. The time now is 10:21 AM.