Go Back   Steve's Digicams Forums > Digicam Help > Studio Lighting, Flash & Other

Reply
 
Thread Tools Search this Thread
Old May 2, 2006, 5:51 PM   #1
Junior Member
 
Join Date: May 2006
Posts: 18
Default

Ok guys bear with my here, I'm totaly new to studio lighting/strobe flash equipment. I was recently given an old Electronic Falshmaster AA series power pack with (2) 200w photogenic umbrella lights this equipment is pretty old but in great condition. To test it, my friend hooked it up with his old nikon 35mm SLR but the camera had no film or battery so naturally the flash didn't go off when the shutter was released, so we charged the unit, turned it off and the two lights fired so i imagined that they do work. I would like to know how to sync it with my 20D, He gave me his old sink cable and the cable that connects to the actual power pack, I have read some online articles that it would be necessary to usea wein safe sync to prevent it from frying my camera. Any help and suggesions is much appreciated.

:|
MIles_ahead is offline   Reply With Quote
Sponsored Links
Old May 13, 2006, 6:00 PM   #2
Junior Member
 
Join Date: May 2006
Posts: 12
Default

II would never connect my cameras directly to an external strobe or studio flash. I use an opto couplerwith a separate low voltage batery that isolates even the ground wire. It is also important that the device apply a very low current to the camera (typical figures are 6 volt, 3 miliamp).I built my opto isolators using opto coupler CIs but I believethe assembled deviceis available in the market. Radio control also protects the camera and I am sure they are ease to find. Old style strobes use to submit the camera to more than 200 V and a very high current peak.

Be carefull and good luck.
Kleber is offline   Reply With Quote
Old Jun 16, 2006, 2:30 PM   #3
Senior Member
 
Ronnie948's Avatar
 
Join Date: Oct 2002
Posts: 721
Default

The safe sync will be fine. I use one for My Travel light 750 strobes. As long as you have a hot shoe it will work. My D100 & D200 have hot shoes. I could plug the Strobe directly into my D200 but why take the chance when I already have a Wein SafeSync.

I guess you already know you will need to put your camera in Manual Mode and meter the strobes with a flash meter to correctly use them. TTL will not function with the studio strobes at all.

Photogenic makes very good lights so even if they are old they should still be fine for portraits and most anything else you want to use them for.

If you do not have a meter you will need to purchase one. Just be positive you get a "FLASH" meter and not just a light meter.

Ronnie
Ronnie948 is offline   Reply With Quote
Old Jun 21, 2006, 1:41 AM   #4
Junior Member
 
Join Date: May 2006
Posts: 18
Default

!!Wow!! Kleber sounds like you know your stuff. Thanks alot for your advice.
MIles_ahead is offline   Reply With Quote
Old Jun 21, 2006, 2:04 AM   #5
Junior Member
 
Join Date: May 2006
Posts: 18
Default

Yea the wein safe sync seems to work just fine with the hot shoe with someoccasional misses here and there, butsyns well most of the time. My lightsand and the battery pack about 20+ yrs old but seem to work ok. And yes I am putting my camera on Manual mode and am currently using a Seconic zoom master L-508 which I bought used for $250.00 bucks. I'll post some picks very soon.

Thanks for the advice Ronnie







MIles_ahead is offline   Reply With Quote
Old Jun 21, 2006, 9:15 AM   #6
Senior Member
 
Ronnie948's Avatar
 
Join Date: Oct 2002
Posts: 721
Default

I can't wait to see the pictures. I'm suer they will be good.

Ronnie


Ronnie948 is offline   Reply With Quote
Old Jun 22, 2006, 1:00 AM   #7
Junior Member
 
Join Date: May 2006
Posts: 18
Default

Here are some pics, let me know what you guys think.

JC



Attached Images
 
MIles_ahead is offline   Reply With Quote
Old Jun 22, 2006, 1:01 AM   #8
Junior Member
 
Join Date: May 2006
Posts: 18
Default

pic 2
Attached Images
 
MIles_ahead is offline   Reply With Quote
Old Jun 22, 2006, 1:01 AM   #9
Junior Member
 
Join Date: May 2006
Posts: 18
Default

pic 3
Attached Images
 
MIles_ahead is offline   Reply With Quote
Old Jun 22, 2006, 1:02 AM   #10
Junior Member
 
Join Date: May 2006
Posts: 18
Default

pic 4
Attached Images
 
MIles_ahead is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:36 PM.