Go Back   Steve's Digicams Forums > Digicam Help > Tips & Tricks

Reply
 
Thread Tools Search this Thread
Old Jan 18, 2009, 5:45 PM   #1
Junior Member
 
Join Date: Jan 2009
Posts: 1
Default

New member here and "hello".

I have a Canon PowerShot A80.It's the model with the moveable LCD monitor.It's an older model I know but it's new to me. I purchased it a little while ago and it's in new condition and had only been used a couple of times.

It's been a great camera but recently the LCD screen or monitor has gone bezerk. It only shows a collage of mixed up colors now. When you first turn it on, it shows the little songbird clearly but then goes into the mixed collage of colors and won't show an image. Everything else on the camera works fine.

Is there anything I can check or do to return it to working order? The batteries are fresh and I checked them and they are all up to snuff. Any advice will be appreciated. Thank you.
Gebe is offline   Reply With Quote
Sponsored Links
Old Jan 30, 2009, 9:21 PM   #2
Junior Member
 
Join Date: Jan 2009
Posts: 3
Default

Yea well,,same problem,Cannon has a recal on the a80 and verious other mods. go to their website search for recals.they will even pay postage
sonnybob1 is offline   Reply With Quote
Old Jan 30, 2009, 9:23 PM   #3
Junior Member
 
Join Date: Jan 2009
Posts: 3
Default

by the way its the ccd.they fixed mine in little over a week
sonnybob1 is offline   Reply With Quote
Old Jan 30, 2009, 9:26 PM   #4
Junior Member
 
Join Date: Jan 2009
Posts: 3
Default

:|sonnybob1 wrote:
Quote:
by the way its the ccd.they fixed mine in little over a week
sonnybob1 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:10 AM.