Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Toshiba (https://forums.steves-digicams.com/toshiba-35/)
-   -   PDR M81 WON'T TURN ON (https://forums.steves-digicams.com/toshiba-35/pdr-m81-wont-turn-14166/)

pagasiano Sep 27, 2003 9:03 AM

PDR M81 WON'T TURN ON
 
In the office, i wasn't able to turn on my camera. I thought it was the battery. When i got home and out on newly-charged Ni-Mh batteries, the unit still won't turn on. That's when i thought of blowing hot air over the unit and inside the battery chamber. After that, i was able to turn it on.

I noticed, however, that even when it's hot, the camera won't switch on. Only after I blow hot air over the body and inside the battery chamber was I able to switch it on. Can somebody please tell me what happened and what I could do. Thanks

wasamoto Sep 27, 2004 3:59 PM

I am having the same problem. I got the camera a bit overheated once or twice leaving it in my vehicle here in Phx metro and it wouldn't turn on until it had cooled for a while.

That was months ago. Camera has been sitting in house for weeks and was working not long ago. Tried to use is yesterday and showed dead batteries. Replaced with new ones, same problem. I paid $400+ for this camera 2-3 years ago. Trying to decide if sending it in for repair is worth it.


Just tried blowing some air through the battery chamber. Put batteries back in, and voila`, it worked. Thanks! It may not work the way it should, but at least it works!


All times are GMT -5. The time now is 7:22 PM.