Go Back   Steve's Digicams Forums > Digicam Help > Tripods and Heads

Reply
 
Thread Tools Search this Thread
Old Jun 25, 2008, 7:04 AM   #1
Junior Member
 
Join Date: Jun 2008
Posts: 3
Default

AF2100 aka pistol grip when the grip is released the head holds whatever position you put it in. the grip feels right in terms of the spring action resistance to it, but when released the head is loose. there is no "locking" mechanism any more. I like to open it and see what "broke". I need instructions on hoe to disassemble the unit. thanks.

photo link


http://www.pbase.com/otfchallenge/image/19228026
iesv is offline   Reply With Quote
Sponsored Links
Old Nov 21, 2008, 12:54 PM   #2
Junior Member
 
Join Date: Nov 2008
Posts: 2
Default

Hi, I have the same problem with my Slik pistol grip head. Did you find a solution?


Thanks,

Geoff
gmax22 is offline   Reply With Quote
Old Nov 21, 2008, 10:11 PM   #3
Junior Member
 
Join Date: Jun 2008
Posts: 3
Default

Yes I have. I tinkered with it, took it apart and then... discovery.

The top part is where you put the camera (duh!), below that is the key to the problem. what seems to be one piece is actually two pieces. you would turn it clockwise I believe (it's been some time) and it would tighten the mechanism. let me rephrase: the black plastic cylindrical part just under the camera mount has a section that turns to release and tighten the grip. look closely and you'll find it. good luck. simon.
iesv is offline   Reply With Quote
Old Nov 22, 2008, 6:01 PM   #4
Junior Member
 
Join Date: Nov 2008
Posts: 2
Default

Thanks a lot Simon I'll give it a try.
gmax22 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:03 PM.