Go Back   Steve's Digicams Forums > Welcome Center > Welcome! Introduce yourself here

Reply
 
Thread Tools Search this Thread
Old Jan 31, 2009, 9:24 PM   #1
Senior Member
 
Join Date: Aug 2004
Posts: 102
Default

Hey All

Ive been away a good long time, tooo long. But Im back,....... (no applause, just throw money...lol...gota pay for my equip......:?...lol)



Steve


SternSteve121 is offline   Reply With Quote
Sponsored Links
Old Feb 1, 2009, 3:14 AM   #2
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,397
Default

Hi Steve,

Good to have you back on board. I would say I've missed youbut you stopped posting before I joined Steve's so sorry to say I didn't LOL.

Looking forward to seeing what you've shot in the past 3 or so years and seeing some new work too.

Get stuck in :G

Mark
Mark1616 is offline   Reply With Quote
Old Feb 1, 2009, 7:32 AM   #3
Senior Member
 
Join Date: Aug 2004
Posts: 102
Default

Good Morning Mark;



lol...Guess ya woulndt have missed me.,....lol.

As I have upgraded my equuipment since I left, and some skill, my posted picsshould be alot better:?When I stopped posting( dang life keeps getting in the way of things huh?) I was using a Fuji FinePix S7000. That has been upgraded to a Canon 30d

I really enjoy this forum(s) here. Most of them are very helpfull.

Ya, Im stuck.....lol

Steve
SternSteve121 is offline   Reply With Quote
Old Feb 1, 2009, 11:46 AM   #4
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,397
Default

Sounds good to me, I also use a 30D sometimes and it is a good little performer so no excuses there LOL.
Mark1616 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:45 AM.