Go Back   Steve's Digicams Forums > Digicam Help > What Camera Should I Buy?

Reply
 
Thread Tools Search this Thread
Old Apr 28, 2005, 9:03 PM   #1
Member
 
pfeels's Avatar
 
Join Date: Apr 2005
Posts: 67
Default

I loved my Kodak LS443. I've had it for a little under three years and suddenly all I get is a blank screen. I searched the Internet and found out that this problem was wide spread along with a lens retracing failure ... Kodak wants $150 to fix plus $35 S&H ... I mentioned this to my friend who purchased one after me and he told me his was sent to the shop and repaired but failed within three months so he bought a Canon ... I will do the same ...

http://www.**********************/koda...0-reviews.html

There are hundreds of reviews that state the same problem ...

I will never buy Kodak again

[email protected]
pfeels is offline   Reply With Quote
Sponsored Links
Old Apr 29, 2005, 9:12 PM   #2
Member
 
pfeels's Avatar
 
Join Date: Apr 2005
Posts: 67
Default

Called Kodak and we worked out a replacement for my faulty camera, they were aware of the LS443 being a problem caused in production and discontinued it but not after a few thousand were sold ... they offered me a new model at a discount price plus and additional $100 Knocked off, so how can you argue, I did get 3 years out of my LS443, Damn, I loved that camera, wish it wasn't the Edsel of it's time...lol, but I'm glad Kodak stepped up to the plate
pfeels is offline   Reply With Quote
Old Apr 29, 2005, 11:59 PM   #3
Senior Member
 
Join Date: Mar 2005
Posts: 113
Default

hehe. you might want to edit your post title. Seems like kodak stepped up.
montana500 is offline   Reply With Quote
Old May 2, 2005, 7:30 PM   #4
Senior Member
 
beernutz's Avatar
 
Join Date: Jan 2005
Posts: 293
Default

Looks like we know your priceto keep quiet now.:blah: Glad you got it worked out.
beernutz is offline   Reply With Quote
Old May 7, 2005, 7:21 AM   #5
Junior Member
 
Join Date: May 2005
Posts: 6
Default

I had a Kodak LS443 and it broke, twice. The first time, the lens mechanism gears stripped, the second time, it just didn't want to take pictures outdoors anymore. No matter what setting I use outdoors, all pictures are white as a sheet.

Kodak has severe quality control issues, and I will NEVER recommend their cameras again. I took the LS443 and threw it into the garbage after I bought a new Canon SLR.
bradenmikael is offline   Reply With Quote
Old May 13, 2005, 6:17 PM   #6
Member
 
pfeels's Avatar
 
Join Date: Apr 2005
Posts: 67
Default

bradenmikael wrote:
Quote:
I had a Kodak LS443 and it broke, twice. The first time, the lens mechanism gears stripped, the second time, it just didn't want to take pictures outdoors anymore. No matter what setting I use outdoors, all pictures are white as a sheet.

Kodak has severe quality control issues, and I will NEVER recommend their cameras again. I took the LS443 and threw it into the garbage after I bought a new Canon SLR.
Kodak admitted the camera was a lemon and had a great trade in deal, $125.00 for a brand new LS7?? ... It takes great pics just like the LS443 did but the burst is 6 and the video is amazing ... To bad you didn't call
pfeels is offline   Reply With Quote
Old May 13, 2005, 10:57 PM   #7
Junior Member
 
alexzkhy's Avatar
 
Join Date: Mar 2005
Posts: 19
Default

I also had a DX-4330, my first digicam. It worked fine for more than a year and then suddenly it just failed. It will power up ok but nothing on the screen except menus. It will take a picture... fire its flash but nothing comes out as all is black in the saved image..... replaced it with Canon IXY Digital50 (SD300)
alexzkhy is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:45 AM.