Go Back   Steve's Digicams Forums > Post Your Photos > Wildlife Photos

Reply
 
Thread Tools Search this Thread
Old Nov 6, 2009, 10:04 PM   #1
Senior Member
 
squirl033's Avatar
 
Join Date: Dec 2004
Posts: 6,699
Default a couple of grebes

went to the park today for the first time in, oh, a month or so, and spotted these grebes just as the light was fading. had to crank the ISO to 1000 to get these, but better than nothing, i suppose...

this Western grebe was too far out for a good shot, so had to crop this a lot, but they aren't common around here, so i wanted to get what i could while the gettin' was good... sort of...



this little pied-bill came in quite a bit closer than usual, just wish the light had been decent!

squirl033 is offline   Reply With Quote
Sponsored Links
Old Nov 6, 2009, 10:17 PM   #2
Senior Member
 
Join Date: Aug 2009
Location: NYC
Posts: 1,990
Default

That second shot is a real winner, bad light of not. I've never actually seen one of these guys, so you've given me a treat!

Well done!

Dave
Chato is offline   Reply With Quote
Old Nov 7, 2009, 4:23 AM   #3
Senior Member
 
Rob_W's Avatar
 
Join Date: Nov 2009
Location: Bowt'n Uk
Posts: 183
Default

Great shots bad light or not
__________________
www.robs-photography.com

My flickr
Rob_W is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:00 AM.